lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 16167] - Problem searching with WildCards and quotes
Date Sun, 19 Jan 2003 08:01:16 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16167>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16167

Problem searching with WildCards and quotes

amiton23@hotmail.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|INVALID                     |



------- Additional Comments From amiton23@hotmail.com  2003-01-19 08:01 -------
i have the same bug!!!
i have written my own Analyzer and it looks like this:
---start code---
public class testAnalyzer extends Analyzer
{
   public TokenStream tokenStream(String fieldName, Reader reader)
   {
      return newtestTokenizer(reader);
   }
}
---end code---

---start code---
public class testTokenizer extends CharTokenizer
{
   public testTokenizer(Reader reader)
   {
      siper(reader);
   }
   protected boolean isTokenChar(char c)
   {
      return true;
   }
}
---end code---

i index the documents with this analyzer and queryparse with the same analyzer.
when i search for "12*" i get a hit but when i search for "\"12*\"" i get no 
hits. so yes indeed this is a bug and if not please tell me what i am doing 
wrong.

thanks,
     Amit

--
To unsubscribe, e-mail:   <mailto:lucene-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:lucene-dev-help@jakarta.apache.org>


Mime
View raw message