lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 14665] New: - QueryParser incorrectly escapes special characters in term names
Date Tue, 19 Nov 2002 01:49:58 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14665>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14665

QueryParser incorrectly escapes special characters in term names

           Summary: QueryParser incorrectly escapes special characters in
                    term names
           Product: Lucene
           Version: 1.2
          Platform: Other
        OS/Version: Windows XP
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: QueryParser
        AssignedTo: lucene-dev@jakarta.apache.org
        ReportedBy: hanson@reactivity.com


Related to bug 11636

Sample:
build a document with a field named "Some-Term", whose value is Text "value".

The query Some-Term:value is parsed as "Some -Term:value", which is arguably
correct.

The query Some\-Term:value is parsed as "Some\-Term:value", which appears
incorrect.  It returns no hits.

The query "Some-Term:value" appears to be parsed as "Some-Term:value" (according
to Query.toString()) but returns no hits.

--
To unsubscribe, e-mail:   <mailto:lucene-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:lucene-dev-help@jakarta.apache.org>


Mime
View raw message