lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Otis Gospodnetic <otis_gospodne...@yahoo.com>
Subject Re: Manifest.mf empty for lucene-1.2.jar
Date Fri, 08 Nov 2002 00:24:35 GMT
This doesn't sound like a manifest issue to me, more like a jar problem
(corrupt jar file or broken `jar').

Otis

--- "Robert A. Decker" <decker@robdecker.com> wrote:
> Thanks. I made these changes to my manifest, then took the old one
> out of
> the jar and added this new one. Unfortunately, I'm still not able to
> build
> on Solaris. I then unzipped the lucene-1.2.jar and added 'org' and
> below
> to a directory in my classpath and I'm now able to build...
> 
> 
> So, it looks like my classpath _is_ set up correctly. However, I
> can't get
> stuff out of the .jar. Is there supposed to be more info in the
> manifest?
> 
> Again, as before, I'm only having this problem on solaris. I can live
> with
> the current situation (having to unzip the jar), but would like to at
> least understand what is wrong...
> 
> thanks,
> rob
> 
> http://www.robdecker.com/
> http://www.planetside.com/
> 
> On Thu, 7 Nov 2002, Otis Gospodnetic wrote:
> 
> > I fixed that in 1.3dev1, the file should now look something like
> this:
> > 
> > Manifest-Version: 1.0
> > Created-By: Apache Jakarta
> > 
> > Name: org/apache/lucene
> > Specification-Title: Lucene Search Engine
> > Specification-Version: ${version}
> > Specification-Vendor: Lucene
> > Implementation-Title: org.apache.lucene
> > Implementation-Version: build ${DSTAMP} ${TSTAMP}
> > Implementation-Vendor: Lucene
> > 
> > 
> > 
> > --- "Robert A. Decker" <decker@robdecker.com> wrote:
> > > I've downloaded lucene and have been using it successfully on
> Win2k.
> > > I'm
> > > now attempting to use it on solaris but am unable to load any of
> the
> > > packages, even though my classpath seems to be set up correctly. 
> > > 
> > > When I looked inside the jar I see that the manifest file only
> has a
> > > couple lines:
> > > Manifest-Version: 1.0
> > > Created-By: Ant 1.4.1
> > > 
> > > 
> > > I'm not sure if this is my problem, but it's something that
> should
> > > probably be fixed...
> > > 
> > > 
> > > thanks,
> > > rob
> > > 
> > > http://www.robdecker.com/
> > > http://www.planetside.com/
> > > 
> > > 
> > > --
> > > To unsubscribe, e-mail:  
> > > <mailto:lucene-dev-unsubscribe@jakarta.apache.org>
> > > For additional commands, e-mail:
> > > <mailto:lucene-dev-help@jakarta.apache.org>
> > > 
> > 
> > 
> > __________________________________________________
> > Do you Yahoo!?
> > U2 on LAUNCH - Exclusive greatest hits videos
> > http://launch.yahoo.com/u2
> > 
> > --
> > To unsubscribe, e-mail:  
> <mailto:lucene-dev-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> <mailto:lucene-dev-help@jakarta.apache.org>
> > 
> 
> 
> 
> --
> To unsubscribe, e-mail:  
> <mailto:lucene-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:lucene-dev-help@jakarta.apache.org>
> 


__________________________________________________
Do you Yahoo!?
U2 on LAUNCH - Exclusive greatest hits videos
http://launch.yahoo.com/u2

--
To unsubscribe, e-mail:   <mailto:lucene-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:lucene-dev-help@jakarta.apache.org>


Mime
View raw message