lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Carlson <>
Subject DateFieldYMD
Date Thu, 11 Jul 2002 15:13:22 GMT

Does anyone have an objection/better idea to adding a new Class called
DateFieldYMD. This would be very similar to DateField, but return a
different format.

This would also support the field dateToString(date) and convert it to the

It would also add
DateTimeToString(date) with the format


Where T is the delimiter between the date and time. Just trying to follow a
pseudo convention and minimize the bits so no delimeter.

The reason why another class vs another method are the supporting methods
such as stringToDate() or stringToTime() which decodes the string to a Date
or a long would be confusing in one class.

I think this would meet the criteria of people who need support before 1970
and be more readable.


To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message