lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 7710] New: - Wildcard query only accepts 1 or more characters for prefixes (not 0 or more)
Date Wed, 03 Apr 2002 08:27:19 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7710>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7710

Wildcard query only accepts 1 or more characters for prefixes (not 0 or more)

           Summary: Wildcard query only accepts 1 or more characters for
                    prefixes (not 0 or more)
           Product: Lucene
           Version: unspecified
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Search
        AssignedTo: lucene-dev@jakarta.apache.org
        ReportedBy: lee@grantadesign.com


When using the WildcardQuery class to do a wildcard search with the wildcard at
the end of the string, the wildcard is treated as "1 or more" characters. This
is inconsistent with other wildcard behaviour, and undesirable. The correct
behaviour is for the wildcard to represent 0 or more characters.

The error is due to a problem in the wildcard comparison method in
org.apache.lucene.search.WildcardTermEnum.

Patch to follow.

--
To unsubscribe, e-mail:   <mailto:lucene-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:lucene-dev-help@jakarta.apache.org>


Mime
View raw message