lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Goetz <br...@quiotix.com>
Subject Re: JDK 1.1 vs 1.2
Date Mon, 21 Jan 2002 05:17:14 GMT
> In working on this I can see the decision on POI is made for us.  POI
> requires JDK 1.2 or better (for performance with collections and
> language encoding reasons) so it will need to be off somewhere in an
> "optional" package.

I think that the time where JDK 1.1 compatibility was an issue is long
past.  Its been _years_ since that's been cited as an issue for any of
my customers or colleagues.  

> Does anyhow have any thoughts on this?  Could we consider upgrading the
> Java 2 collections at least internally?  I would be happy to submit
> patches for this.

Seems sensible to me.  Also, JDK 1.1-based programs use Vector, which
is synchronized, and therefore slower; in general, ArrayList is
preferable, although you need to be careful and try to figure out
whether a synchronized collection is actually needed.

--
To unsubscribe, e-mail:   <mailto:lucene-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:lucene-dev-help@jakarta.apache.org>


Mime
View raw message