lucene-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ctarg...@apache.org
Subject lucene-solr:branch_7x: Ref Guide: add step to install asciidoctor before jekyll-asciidoc to prevent wrong version of gem being installed as a dependency
Date Thu, 17 May 2018 20:03:47 GMT
Repository: lucene-solr
Updated Branches:
  refs/heads/branch_7x 3802f707e -> 730e154d9


Ref Guide: add step to install asciidoctor before jekyll-asciidoc to prevent wrong version
of gem being installed as a dependency


Project: http://git-wip-us.apache.org/repos/asf/lucene-solr/repo
Commit: http://git-wip-us.apache.org/repos/asf/lucene-solr/commit/730e154d
Tree: http://git-wip-us.apache.org/repos/asf/lucene-solr/tree/730e154d
Diff: http://git-wip-us.apache.org/repos/asf/lucene-solr/diff/730e154d

Branch: refs/heads/branch_7x
Commit: 730e154d9474be661ff416f5da8087e093fe5933
Parents: 3802f70
Author: Cassandra Targett <ctargett@apache.org>
Authored: Thu May 17 15:02:30 2018 -0500
Committer: Cassandra Targett <ctargett@apache.org>
Committed: Thu May 17 15:03:40 2018 -0500

----------------------------------------------------------------------
 solr/solr-ref-guide/README.adoc | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/lucene-solr/blob/730e154d/solr/solr-ref-guide/README.adoc
----------------------------------------------------------------------
diff --git a/solr/solr-ref-guide/README.adoc b/solr/solr-ref-guide/README.adoc
index b161396..279ad68 100644
--- a/solr/solr-ref-guide/README.adoc
+++ b/solr/solr-ref-guide/README.adoc
@@ -25,7 +25,8 @@ These files are processed with AsciiDoctor in 2 different ways:
 
 * Via Jekyll to build an HTML browsable version of the Ref Guide.
 ** Prerequisites: `Ruby` (v2.1 or higher) and the following gems must be installed:
-*** `jekyll`: v3.5, not v4.x. Use `gem install --force --version 3.5.0 jekyll` to force install
of Jekyll 3.5.0.
+*** `jekyll`: v3.5, not v4.x. Use `gem install jekyll --force --version 3.5.0` to force install
of Jekyll 3.5.0.
+*** `asciidoctor`: v1.5.6.2, not 1.5.7 or higher. Use `gem install asciidoctor --force --version
1.5.6.2`. NOTE: You must do this before installing `jekyll-asciidoc` or you'll get a version
of Asciidoctor that we can't use yet.
 *** `jekyll-asciidoc`: v2.1 or higher. Use `gem install jekyll-asciidoc` to install.
 *** `pygments.rb`: v1.1.2 or higher. Use `gem install pygments.rb` to install.
 * Via `asciidoctor-ant` to build the officially released PDF version of the Ref Guide.


Mime
View raw message