lucene-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sar...@apache.org
Subject [1/2] lucene-solr:master: install asciidoctor gem before jekyll-asciidoc, to prevent installation of a too-new version of asciidoctor
Date Thu, 17 May 2018 21:33:13 GMT
Repository: lucene-solr
Updated Branches:
  refs/heads/branch_7x 730e154d9 -> 11346faf4
  refs/heads/master 7bb3e5c24 -> 9cbaf327e


install asciidoctor gem before jekyll-asciidoc, to prevent installation of a too-new version
of asciidoctor


Project: http://git-wip-us.apache.org/repos/asf/lucene-solr/repo
Commit: http://git-wip-us.apache.org/repos/asf/lucene-solr/commit/9cbaf327
Tree: http://git-wip-us.apache.org/repos/asf/lucene-solr/tree/9cbaf327
Diff: http://git-wip-us.apache.org/repos/asf/lucene-solr/diff/9cbaf327

Branch: refs/heads/master
Commit: 9cbaf327e8c0240b948f5eaaa333baf3a4282be9
Parents: 7bb3e5c
Author: Steve Rowe <sarowe@apache.org>
Authored: Thu May 17 17:32:41 2018 -0400
Committer: Steve Rowe <sarowe@apache.org>
Committed: Thu May 17 17:32:41 2018 -0400

----------------------------------------------------------------------
 dev-tools/scripts/jenkins.build.ref.guide.sh | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/lucene-solr/blob/9cbaf327/dev-tools/scripts/jenkins.build.ref.guide.sh
----------------------------------------------------------------------
diff --git a/dev-tools/scripts/jenkins.build.ref.guide.sh b/dev-tools/scripts/jenkins.build.ref.guide.sh
index 95aa892..ccc1487 100755
--- a/dev-tools/scripts/jenkins.build.ref.guide.sh
+++ b/dev-tools/scripts/jenkins.build.ref.guide.sh
@@ -5,7 +5,8 @@
 # under solr/solr-ref-guide: "ant clean build-site build-pdf".
 #
 # The following will be downloaded and installed into $HOME/.rvm/:
-# RVM, Ruby, and Ruby gems jekyll, jekyll-asciidoc, and pygments.rb.
+# RVM, Ruby, and Ruby gems jekyll, asciidoctor, jekyll-asciidoc, 
+# and pygments.rb.
 #
 # The script expects to be run in the top-level project directory.
 #
@@ -58,9 +59,9 @@ echoRun "rvm $RUBY_VERSION@$GEMSET"      # Activate this project's gemset
 
 # Install gems in the gemset.  Param --force disables dependency conflict detection.
 echoRun "gem install --force --version 3.5.0 jekyll"
+echoRun "gem install --force --version 1.5.6.2 asciidoctor"
 echoRun "gem install --force --version 2.1.0 jekyll-asciidoc"
 echoRun "gem install --force --version 1.1.2 pygments.rb"
-echoRun "gem install --force --version 1.5.6.2 asciidoctor"
 
 cd solr/solr-ref-guide
 


Mime
View raw message