lucene-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dwe...@apache.org
Subject svn commit: r1331284 - in /lucene/dev/trunk: lucene/BUILD.txt lucene/CHANGES.txt lucene/common-build.xml solr/README.txt
Date Fri, 27 Apr 2012 08:02:53 GMT
Author: dweiss
Date: Fri Apr 27 08:02:53 2012
New Revision: 1331284

URL: http://svn.apache.org/viewvc?rev=1331284&view=rev
Log:
LUCENE-4016: require ant 1.8.2 or later. Sorry Uwe.

Modified:
    lucene/dev/trunk/lucene/BUILD.txt
    lucene/dev/trunk/lucene/CHANGES.txt
    lucene/dev/trunk/lucene/common-build.xml
    lucene/dev/trunk/solr/README.txt

Modified: lucene/dev/trunk/lucene/BUILD.txt
URL: http://svn.apache.org/viewvc/lucene/dev/trunk/lucene/BUILD.txt?rev=1331284&r1=1331283&r2=1331284&view=diff
==============================================================================
--- lucene/dev/trunk/lucene/BUILD.txt (original)
+++ lucene/dev/trunk/lucene/BUILD.txt Fri Apr 27 08:02:53 2012
@@ -1,14 +1,14 @@
 Lucene Build Instructions
 
 Basic steps:
-  0) Install JDK 1.6 (or greater), Ant 1.7.1+ (not 1.6.x, not 1.8.x), Ivy 2.2.0
+  0) Install JDK 1.6 (or greater), Ant 1.8.2+, Ivy 2.2.0
   1) Download Lucene from Apache and unpack it
   2) Connect to the top-level of your Lucene installation
   3) Install JavaCC (optional)
   4) Run ant
 
 Step 0) Set up your development environment (JDK 1.6 or greater,
-Ant 1.7.1+, Ivy 2.2.0)
+Ant 1.8.2+, Ivy 2.2.0)
 
 We'll assume that you know how to get and set up the JDK - if you
 don't, then we suggest starting at http://java.sun.com and learning
@@ -16,7 +16,7 @@ more about Java, before returning to thi
 JDK 1.6 and later.
 
 Like many Open Source java projects, Lucene uses Apache Ant for build
-control.  Specifically, you MUST use Ant version 1.7.1+
+control.  Specifically, you MUST use Ant version 1.8.2+.
 
 Ant is "kind of like make without make's wrinkles".  Ant is
 implemented in java and uses XML-based configuration files.  You can

Modified: lucene/dev/trunk/lucene/CHANGES.txt
URL: http://svn.apache.org/viewvc/lucene/dev/trunk/lucene/CHANGES.txt?rev=1331284&r1=1331283&r2=1331284&view=diff
==============================================================================
--- lucene/dev/trunk/lucene/CHANGES.txt (original)
+++ lucene/dev/trunk/lucene/CHANGES.txt Fri Apr 27 08:02:53 2012
@@ -944,6 +944,8 @@ Documentation
 
 Build
 
+* LUCENE-4016: Require ANT 1.8.2+ for the build. 
+
 * LUCENE-3808: Refactoring of testing infrastructure to use randomizedtesting
   package: http://labs.carrotsearch.com/randomizedtesting.html (Dawid Weiss)
 

Modified: lucene/dev/trunk/lucene/common-build.xml
URL: http://svn.apache.org/viewvc/lucene/dev/trunk/lucene/common-build.xml?rev=1331284&r1=1331283&r2=1331284&view=diff
==============================================================================
--- lucene/dev/trunk/lucene/common-build.xml (original)
+++ lucene/dev/trunk/lucene/common-build.xml Fri Apr 27 08:02:53 2012
@@ -236,6 +236,13 @@
     <isset property="fetch.sources.javadocs"/>
   </condition>
 
+  <!-- Check for minimum supported ANT version. -->
+  <fail message="Minimum supported ANT version is 1.8.2. Yours: ${ant.version}">
+    <condition>
+      <not><antversion atleast="1.8.2" /></not>
+    </condition>
+  </fail>
+
   <!-- Import custom ANT tasks. -->
   <import file="${common.dir}/tools/custom-tasks.xml" />
 

Modified: lucene/dev/trunk/solr/README.txt
URL: http://svn.apache.org/viewvc/lucene/dev/trunk/solr/README.txt?rev=1331284&r1=1331283&r2=1331284&view=diff
==============================================================================
--- lucene/dev/trunk/solr/README.txt (original)
+++ lucene/dev/trunk/solr/README.txt Fri Apr 27 08:02:53 2012
@@ -66,7 +66,7 @@ Instructions for Building Apache Solr fr
    folder included on your command path. To test this, issue a "java -version" command 
    from your shell (command prompt) and verify that the Java version is 1.6 or later.
 
-2. Download the Apache Ant binary distribution (1.7.x, not 1.6.x, not 1.8.x) from 
+2. Download the Apache Ant binary distribution (1.8.2+) from 
    http://ant.apache.org/  You will need Ant installed and the $ANT_HOME/bin (Windows: 
    %ANT_HOME%\bin) folder included on your command path. To test this, issue a 
    "ant -version" command from your shell (command prompt) and verify that Ant is 



Mime
View raw message