logging-log4php-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pedro Cristovao <pcristo...@dcc.online.pt>
Subject Log4php+chainsaw=error?
Date Fri, 22 Apr 2005 15:00:40 GMT
Hello!

I'm trying to figure out how the following problem occurs, and I sure
need some help:

I'm using log4php in my application, and I defined my own error handler,
wich logs the errors to controller.log. My log4php configuration file
contains this:

log4php.logger.Access=INFO, A1, A3
log4php.logger.Controller=WARN, A2, A3
;----------------------------------------------------------------------
log4php.appender.A1=LoggerAppenderRollingFile
log4php.appender.A1.filename="logs/access.log"
log4php.appender.A1.MaxFileSize=10MB
log4php.appender.A1.MaxBackupIndex=1
log4php.appender.A1.layout=LoggerLayoutTTCC
log4php.appender.A1.layout.ContextPrinting="true"
log4php.appender.A1.layout.DateFormat="%c"
;----------------------------------------------------------------------
log4php.appender.A2=LoggerAppenderRollingFile
log4php.appender.A2.filename="logs/controller.log"
log4php.appender.A2.MaxFileSize=10MB
log4php.appender.A2.MaxBackupIndex=1
log4php.appender.A2.layout=LoggerLayoutTTCC
log4php.appender.A2.layout.ContextPrinting="true"
log4php.appender.A2.layout.DateFormat="%c"
;----------------------------------------------------------------------
log4php.appender.A3=LoggerAppenderSocket 
log4php.appender.A3.remoteHost=localhost
log4php.appender.A3.port=4445
log4php.appender.A3.layout=LoggerXmlLayout
log4php.appender.A3.useXml=true

The problem is that while Chainsaw is getting the messages, I get this
error in controller.log:

Error string: Undefined index:  class
Error file: /log4php/spi/LoggerLoggingEvent.php
Error line: 189

But if I quit Chainsaw, this error doesn't occur.

My Chainsaw configuration file is this:

<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE log4j:configuration >
<log4j:configuration xmlns:log4j="http://jakarta.apache.org/log4j/"
debug="true">
   <plugin name="SGL_XMLSocketReceiver"
class="org.apache.log4j.net.XMLSocketReceiver">
      <param name="decoder" value="org.apache.log4j.xml.XMLDecoder"/>
      <param name="Port" value="4445"/>
   </plugin>
   <root>
      <level value="debug"/>
   </root>
</log4j:configuration>


Can anyone help me? Thanks in advance!

Pedro C.


Mime
View raw message