logging-log4php-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Hammers ...@lathspell.de>
Subject How to change the Maven dependency to Doxia?
Date Sun, 06 Sep 2009 21:06:41 GMT
Hi

Sometimes I wish back the good ol' Makefile... why is Maven insisting
on using doxia 1.0-alpha-11? There is no visible dependency in the
pom.xml and it does so even if I add a dependency to 1.1.1:

       <dependency>                                                                

                        <groupId>org.apache.maven.doxia</groupId>            
               
                        <artifactId>doxia</artifactId>                       
               
                        <version>1.1.1</version>                             
               
                        <type>pom</type>                                     
               
       </dependency>   
 
 $ mvn site
 ...
 [INFO] Building Apache log4php. [INFO]    task-segment: [site]
 [INFO]
 ------------------------------------------------------------------------
 Downloading:
 http://mirror.netcologne.de/maven2/org/apache/maven/doxia/doxia-core/1.0-alpha-11/doxia-core-1.0-alpha-11.jar
 ...

The reason I want 1.0+ is that it supports %{snippet} .apt macros that
include the whole file.

Ok, since most of the files include this big fat Apache copyright header
maybe it would indeed be better to use the "// START SNIPPET: foo" tag
but I would still be curious if anybody can explain me Maven :)

bye,

-christian-

Mime
View raw message