logging-log4net-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Douglas Neary <dne...@miteksystems.com>
Subject RE: log4net rolling file appender losing log files during roll over
Date Thu, 16 Jan 2014 22:23:59 GMT
Hi Dominik:

Thanks for the reply.

>> I've looked at the logfile [2] and all starts with the .log file not being rolled
cause the file is still open and thus can't be moved. The following warnings are caused by
the first error. So this is where the trouble starts:

Agreed.

>> My first guess is that there are multiple processes logging into the same file.

I don't believe that is the case.    Let me explain further...

This is an Asp.net application (.Net 3.5.1) with 3 separate web sites logging to 3 separate
log files using the rolling file appender.
To be more specific, see the table below:

Folder

Log File Name

App Pool

c:\inetpub\wwwroot\mobiledeposit

C:\logs\mobile_deposit_web.log

DefaultAppPool

C:\inetpub\wwwroot\remotecarlar

C:\logs\mobile_deposit_remotecarlar.log

Remote_CarLar

C:\inetpub\wwwroot\remote_RE

C:\logs\mobile_deposit_remoteRE.log

Remote_RE


Since each of these 3 sites is running in a separate App Pool, they are each running in a
separate (32 bit) w3wp.exe.  There are 3 workers, each named w3wp.exe with different PIDs.
 .  I added a screen shot from Process Explorer to the Jira ticket to show you what I mean.

App Domain Recycling has been disabled for each of these sites (I added another screen shot
to Jira).  The Jira url for this issue is https://issues.apache.org/jira/browse/LOG4NET-416.

So my questions:

1.      Am I doing anything obviously wrong?

2.     Assuming the answer to #1 is wrong, how can I help further?

Thanks,
Doug


p.s.  I chopped off the rest of this email, please let me know if that was a bad idea.

Mime
View raw message