logging-log4net-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Whatmore <Steven.Whatm...@purefacts.com>
Subject RE: Issues with deploying log4net
Date Wed, 17 Apr 2013 19:29:09 GMT
Further to that first email - it sounds like you are not running the same version of the DLL(s)
when you deploy - otherwise you would already have run across this issue locally


From: Steven Whatmore [mailto:Steven.Whatmore@purefacts.com]
Sent: April-17-13 3:25 PM
To: Log4NET User
Subject: RE: Issues with deploying log4net

There has been a number of posts about this and you can probably find what you need on the
net somewhere but essentially you need an assembly binding in your web.config I believe -
it should be something like the following (only an example)

<runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="Common.Logging" publicKeyToken="af08829b84f0328e"/>
        <bindingRedirect oldVersion="0.0.0.0-65535.65535.65535.65535" newVersion="2.1.1.0"/>
      </dependentAssembly>
    </assemblyBinding>
</runtime>



Steve Whatmore, MBA, MCP, .NET
Software Development Manager / Architect
416.598.1241 x245
-------------------------------------------------
PureFacts Financial Solutions
372 Bay Street, Suite 1400
Toronto, Ontario M5H 2W9
416.598.1241 main
888.596.9338 toll free
416.598.9226 fax
www.purefacts.com<http://www.purefacts.com>
Please consider the environment before printing this e-mail.
This e-mail may be privileged and/or confidential, and the sender does not waive any related
rights and obligations. Any distribution, use or copying of this e-mail or the information
it contains by other than an intended recipient is unauthorized. If you received this e-mail
in error, please advise me (by return e-mail or otherwise) immediately.
Ce courrier électronique est confidentiel et protégé. L'expéditeur ne renonce pas aux
droits et obligations qui s'y rapportent. Toute diffusion, utilisation ou copie de ce message
ou des renseignements qu'il contient par une personne autre que le (les) destinataire(s) désigné(s)
est interdite. Si vous recevez ce courrier électronique par erreur, veuillez m'en aviser
immédiatement, par retour de courrier électronique ou par un autre moyen.



From: Ron Daggett [mailto:rdaggett@rxcrossroads.com]
Sent: April-17-13 3:13 PM
To: log4net-user@logging.apache.org<mailto:log4net-user@logging.apache.org>
Subject: Issues with deploying log4net

I'm having an issue with log4net version 1.2.9.0. When I deploy my app locally, it runs as
expected. When I try and deploy to a QA Web server, I get the following message when I try
and open the page:

[cid:image001.png@01CE3B80.4E3BD600]

Thank you in advance for any assistance you can provide.

Thank you,

Ron Daggett
Software Developer
RxCrossroads
Office: 502-963-0059
Cell: 502-303-8312
Fax: 502-322-1012
rdaggett@rxcrossroads.com<mailto:rdaggett@rxcrossroads.com>

This information transmitted is intended only for the person or entity to which it is addressed
and may contain confidential and/or privileged material, the disclosure of which is governed
by applicable law.  Any review, retransmission, dissemination or other use of, or taking of
any action in reliance upon, this information by persons or entities other than the intended
recipient is prohibited.  If you received this in error, please contact me and destroy the
materials contained in this message.


Mime
View raw message