logging-log4net-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Problems compiling log4net under NetBSD
Date Wed, 05 Oct 2011 03:57:25 GMT
On 2011-10-05, Silas Silva wrote:

> I'm trying to compile log4net under the NetBSD operating system.  Both
> Mono and nant are compiled and working.  But I'm getting some errors
> that I can't handle.  Here they are: http://pastebin.com/hpPaipXX

> NAnt is 0.86 and Mono is 2.8.2.

Yes, I've seen that as well when using Mono > 2.6 (which is what I'll
use for the upcoming release) and intend to fix those problems in trunk
after the 1.2.11 release.

Unless you can downgrade Mono to 2.6.x, another workaround for now would
be to not turn warnings into errors or explicitly ignore the warnings.
You'd need to modify the csc tasks inside the compile-mono-2.0 target
and either set the warnaserror attribute to false or add 1574 and 0419
to the nowarn element.

Stefan

Mime
View raw message