logging-log4net-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Radovan Raszka" <ras...@hasam.cz>
Subject RE: Error while sending Mail to smtp.gmail.com
Date Tue, 21 Jul 2009 09:51:50 GMT
One more idea - is there any antivirus / firewall software on the computer you are doing your
tests? It can block communication - I had to switch outgoing mail checking off somewhere in
the past....
RR


________________________________

Od: Sree [mailto:sree.optust@gmail.com] 
Odesláno: 21. července 2009 11:02
Komu: 'Log4NET User'
Předmět: RE: Error while sending Mail to smtp.gmail.com



 

But I'm getting error:

 

 

A first chance exception of type 'System.InvalidOperationException' occurred in log4netTests.exe

log4net:ERROR [SmtpAppender] Error occurred while sending e-mail notification.

System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client
was not authenticated. The server response was: 5.7.0 Must issue a STARTTLS command first.
22sm14461822wfd.8

   at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)

   at System.Net.Mail.MailCommand.Send(SmtpConnection conn, Byte[] command, String from)

   at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients,
String deliveryNotify, SmtpFailedRecipientException& exception)

   at System.Net.Mail.SmtpClient.Send(MailMessage message)

   at log4net.Appender.SmtpAppender.SendEmail(String messageBody)

   at log4net.Appender.SmtpAppender.SendBuffer(LoggingEvent[] events)

 

 

Do I need to do any other specific settings..

 

Please help me out...and I really Thank for ur responses...

 

Best regards,

Sree

 

 

 

________________________________

From: Radovan Raszka [mailto:raszka@hasam.cz] 
Sent: Tuesday, July 21, 2009 1:15 AM
To: Log4NET User
Subject: RE: Error while sending Mail to smtp.gmail.com

 

Works for me without any configuration exception. I had only to change port to 25, why you
are trying 465? My config:

<appender name="SmtpAppender" type="log4net.Appender.SmtpAppender">

<to value="raszka@hasam.cz" />

<from value="myusername@gmail.com " />

<subject value="test logging message" />

<smtpHost value="smtp.gmail.com" />

<authentication value = "Basic" />

<username value = "username" />

<password value = "mypassword" />

<enablessl value ="true"/>

<port value ="25"/>

<bufferSize value="512" />

<lossy value="false" />

<evaluator type="log4net.Core.LevelEvaluator">

<threshold value="ALL"/>

</evaluator>

<layout type="log4net.Layout.PatternLayout">

<conversionPattern value="%newline%date [%thread] %-5level %logger [%property{NDC}] - %message%newline%newline%newline"
/>

</layout>

</appender>

RR

________________________________

Od: Sree [mailto:sree.optust@gmail.com] 
Odesláno: 20. července 2009 9:50
Komu: 'Log4NET User'
Předmět: RE: Error while sending Mail to smtp.gmail.com

No this also didn't work out...

 

________________________________

From: Radovan Raszka [mailto:raszka@hasam.cz] 
Sent: Friday, July 17, 2009 4:53 PM
To: Log4NET User
Subject: RE: Error while sending Mail to smtp.gmail.com

 

strange, this property exists in source code taken from source repository. But doesn't exist
in binary distribution (even there is no ssl property!), so try to get current sources from
repository, compile and try again....

Radovan

 

________________________________

Od: Sree [mailto:sree.optust@gmail.com] 
Odesláno: 17. července 2009 13:09
Komu: 'Log4NET User'
Předmět: RE: Error while sending Mail to smtp.gmail.com

log4net:ERROR XmlHierarchyConfigurator: Cannot find Property [enablessl] to set object on
[log4net.Appender.SmtpAppender]

 

getting the above error

 

Best regards,

Sree

 


Mime
View raw message