logging-log4net-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Radovan Raszka" <ras...@hasam.cz>
Subject RE: Error while sending Mail to smtp.gmail.com
Date Fri, 17 Jul 2009 08:13:55 GMT
According to documentation, there is no Ssl property for SmtpAppender.
According source code it is named EnableSsl, so repair your config.
But I'm not sure if it helps...
Radovan Raszka


________________________________

From: Sree [mailto:sree.optust@gmail.com] 
Sent: Friday, July 17, 2009 12:30 PM
To: 'log4net-user@logging.apache.org'
Subject: Error while sending Mail to smtp.gmail.com

 

--> I'm able to successfully send mail using .net code through gmail by
enabling SSL.

 

But using log4net its given error:

 

My Code in app.config file: 

 

     <appender name="SmtpAppender" type="log4net.Appender.SmtpAppender">

      <to value="myusername@gmail.com" />

      <from value=" myusername@gmail.com " />

      <subject value="test logging message" />

      <smtpHost value="smtp.gmail.com" />

      <authentication value = "Basic" />

      <username value = " myusername@gmail.com " />

      <password value = "mypassword" />

      <ssl value ="true"/>

      <port value ="465"/>

      <bufferSize value="512" />

      <lossy value="true" />

      <evaluator type="log4net.Core.LevelEvaluator">

        <threshold value="ALL"/>

      </evaluator>

      <layout type="log4net.Layout.PatternLayout">

        <conversionPattern value="%newline%date [%thread] %-5level
%logger [%property{NDC}] - %message%newline%newline%newline" />

      </layout>

    </appender>

 

 

 

Getting error:

 

log4net:ERROR [SmtpAppender] Error occurred while sending e-mail
notification.

System.Net.Mail.SmtpException: The operation has timed out.

   at System.Net.Mail.SmtpClient.Send(MailMessage message)

   at log4net.Appender.SmtpAppender.SendEmail(String messageBody)

   at log4net.Appender.SmtpAppender.SendBuffer(LoggingEvent[] events)

 

 

 

I tried using STARTTLS protocol also...which gave me an error with
authentication and so....

 

 

 

Please help me out....I deadly need it work it down...

 

Best regards,

Sree


Mime
View raw message