logging-log4net-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robin Shahan" <Robin.Sha...@goldmail.com>
Subject RE: Log4Net stopping
Date Wed, 19 Mar 2008 15:11:50 GMT
The file is being uploaded to our servers via web services. I don't see
how it can be related (it's not a new feature), but that is the pattern
we're seeing -- logging stops for some people after they've uploaded.
One thing to note: There is a lot of logging done during the upload
process.

 

One other thing - I remembered last night that I've seen this in one
other case. I put some logging statements in this click event in a user
control once, and it wouldn't output the statements. I ended up putting
in messageboxes to get the information I was looking for.

 

And the other programmer who has seen this problem said the log messages
don't show up in the Output window in Visual Studio either.

 

Here is our configuration file. I didn't add the logging to our
application, another programmer did, who is long gone. So I don't know a
whole lot about log4net, except how it's set up in our app (it starts
first thing), where the logs go, and how to write to the log. That, and
it's worked great right up to this moment. 

 

<?xml version="1.0" encoding="utf-8"?>

<log4net>

  <appender name="ConsoleAppender"
type="log4net.Appender.ConsoleAppender">

    <layout type="log4net.Layout.PatternLayout">

      <conversionPattern value="%date %-5level %logger (%L) [%ndc] -
%message%newline" />

    </layout>

  </appender>

  <appender name="RollingLogFileAppender"
type="log4net.Appender.RollingFileAppender">

    <file value="D:\RobinShahan\GoldMail\GoldMailLog.txt" />

    <staticLogFileName value="true" />

    <appendToFile value="true" />

    <rollingStyle value="Size" />

    <maxSizeRollBackups value="5" />

    <maximumFileSize value="1MB" />

    <layout type="log4net.Layout.PatternLayout">

      <conversionPattern
value="GMLog#%date;%-5level;%logger(%L);%message#End%newline" />

    </layout>

  </appender>

  <root>

    <level value="DEBUG" />

    <appender-ref ref="ConsoleAppender" />

    <appender-ref ref="RollingLogFileAppender" />

  </root>

</log4net>

 

Thanks,

Robin Shahan

GoldMail.com

From: Dean Fiala [mailto:dfiala@celadonlabs.com] 
Sent: Wednesday, March 19, 2008 5:56 AM
To: 'Log4NET User'
Subject: RE: Log4Net stopping

 

Robin,

No answers, but some questions: Is the file being uploaded to the same
directory as the log?  Dose the size of the file being uploaded matter?
Which appenders are you using?

 

Regards,

 

Dean Fiala

 

 

________________________________

From: Robin Shahan [mailto:Robin.Shahan@goldmail.com] 
Sent: Tuesday, March 18, 2008 8:53 PM
To: log4net-user@logging.apache.org
Subject: Log4Net stopping

We are using log4net to do logging in a .Net 2.0 application. We have
used it successfully for about 6 months. Then today, we discovered that
sometimes it just stops working. It still goes through the statements to
write to the log, but it doesn't actually write anything anywhere. The
users have to close our application and re-open it to start the logging
off again. 

 

The action that happens right before it stops is uploading a file via
web services. The file succeeds, and shortly thereafter it stops
logging. I don't know if that's coincidence or what. We are not seeing
this on all the customers, just some, and for those, some are
intermittent and some are always happening.

 

We are running the most current version (1.2.10).

 

Any help would be greatly appreciated.

 

Robin Shahan

Sr. Software Engineer

GoldMail, Inc.

robin.shahan@goldmail.com 

 


Mime
View raw message