logging-log4net-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ron Grabowski <rongrabow...@yahoo.com>
Subject Re: The current target framework (Microsoft .NET Framework 3.5) is not supported by log4net
Date Thu, 28 Feb 2008 20:56:24 GMT
I added support for 3.0 and 3.5 to the build scripts. log4net doesn't use any 3.0 or 3.5 specific
code at the moment. The existing .NET 2.0 assemblies are the best choice for 3.0 and 3.5.
I think there's a bug in the latest nant beta where a 3.5 compile actually uses the 2.0 System
assemblies.

----- Original Message ----
From: Mike Baker <mike.baker@harmonicinc.com>
To: log4net-user@logging.apache.org
Sent: Wednesday, February 6, 2008 10:07:28 PM
Subject: The current target framework (Microsoft .NET Framework 3.5) is not supported by log4net

  
<!--

 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
	{margin:0in;margin-bottom:.0001pt;font-size:12.0pt;font-family:"Times New Roman";}
a:link, span.MsoHyperlink
	{color:blue;text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
	{color:purple;text-decoration:underline;}
span.EmailStyle17
	{font-family:Arial;color:windowtext;}
span.EmailStyle18
	{font-family:Arial;color:navy;}
 _filtered {margin:1.0in 1.25in 1.0in 1.25in;}
div.Section1
	{}
-->
I have recently installed Visual Studio 2008 which uses
Microsoft .NET Framework 3.5.  When I tried to build log4net, I got the
message “The current target framework (Microsoft .NET Framework 3.5) is
not supported by log4net.”
   
 Is there a workaround?  If not, when will 3.5 be
supported by log4net?
   
 Thanks,
 -Mike
 




Mime
View raw message