logging-log4net-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nmarun <nmar...@hotmail.com>
Subject RE: %l to %level difference..
Date Mon, 30 Apr 2007 18:27:18 GMT

Hi Nick,

I was using an older version. The latest one works perfectly fine. Thanks
again
Arun

nicko wrote:
> 
> Which version of log4net are you using?
> 
> ------------
> Nicko Cadell
> log4net development
> http://logging.apache.org/log4net
> 
> -----Original Message-----
> From: nmarun [mailto:nmarun8@hotmail.com] 
> Sent: 30 April 2007 18:36
> To: log4net-user@logging.apache.org
> Subject: %l to %level difference..
> 
> 
> Hi,
> 
> I'm having an trouble with %l and %level specifiers. My
> RollingLogFileAppender is as below:
> 
> [CODE]
> 
> <appender name="RollingLogFileAppender"
> type="log4net.Appender.RollingFileAppender">
> 	<file value="..\\Logs\\CurrentLog.log" />
> 	<appendToFile value="true" />
> 	<datePattern value="yyyyMMdd" />
> 	<rollingStyle value="Date" />
> 	<filter type="log4net.Filter.LevelRangeFilter">
> 		<acceptOnMatch value="true" />
> 		<levelMin value="INFO" />
> 		<levelMax value="FATAL" />
> 	</filter>
> 	<layout type="log4net.Layout.PatternLayout">
> 		<conversionPattern value="%level" />
> 	</layout>
> </appender>
> [/CODE]
> 
> When i look into the log file, I see a value of:
> 
> 'Log4NetWeb.Default.Page_Load(c:\arun\testprojects\log4netsamplesolution
> \log4netweb\default.aspx.cs:39)evel'
> 
> It seems like the conversion of %l is occurring first, thus showing the
> location and then 'evel' is appended to it. How do I correct it?
> 
> Thanks in advance,
> Arun
> -- 
> View this message in context:
> http://www.nabble.com/-l-to--level-difference..-tf3670928.html#a10257481
> Sent from the Log4net - Users mailing list archive at Nabble.com.
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/-l-to--level-difference..-tf3670928.html#a10258320
Sent from the Log4net - Users mailing list archive at Nabble.com.


Mime
View raw message