logging-log4net-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ron Grabowski <rongrabow...@yahoo.com>
Subject Re: Problem with log4net
Date Wed, 15 Feb 2006 23:36:35 GMT
Your program runs fine with the latest build of log4net from
svn.apache.org, Visual Studio 2003, .NET 1.1, and Windows XP
Professional.

--- Andrew Steiger <Andrew.Steiger@refinery.com> wrote:

> I have created a test console application...
> 
>  
> 
> using System;
> 
> using log4net;
> 
>  
> 
> namespace ConsoleApplication1
> 
> {
> 
>       /// <summary>
> 
>       /// Summary description for Class1.
> 
>       /// </summary>
> 
>       class Class1
> 
>       {
> 
>             /// <summary>
> 
>             /// The main entry point for the application.
> 
>             /// </summary>
> 
>             [STAThread]
> 
>             static void Main(string[] args)
> 
>             {
> 
>                   log4net.Config.BasicConfigurator.Configure();
> 
>                   Console.WriteLine("Hello World");
> 
>                   Console.ReadLine();
> 
>             }
> 
>       }
> 
> }
> 
>  
> 
> When I run this class I get a SecurityException from an unknown
> module.
> If I remove the log4net.Config.BasicConfigurator.Configure() line,
> the
> app runs through fine.
> 
>  
> 
> Any ideas what could be causing this error?
> 
>  
> 
> Thanks in advance...
> 
>  
> 
> Andrew. 
> 
> andrew.steiger
> software engineer
> 267.615.2210 
> 
> refinery
> top 30 US interactive agency
> http://www.refinery.com/whitepapers.aspx
> 


Mime
View raw message