logging-log4net-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Naeem Ullah Khan <naeemul...@gmail.com>
Subject Re: MinimalLock not working
Date Mon, 05 Dec 2005 13:00:56 GMT
Got it.
Thanks


On 12/5/05, Ron Grabowski <rongrabowski@yahoo.com> wrote:
>
> According to Sourceforge, log4net v1.1.1 was released in 2002. Only the
> current version, v1.2.9 beta, supports file locking modes.
>
> --- Naeem Ullah Khan <naeemullah@gmail.com> wrote:
>
> > Hi All,
> >
> > I am using log4net v1.1.1.33753. I want to use single log file for
> > all the
> > instances of my application (if any). Thats why I am using following
> > settings in my configuration file but its not working, only first
> > instance
> > of the application is allowing to log messages in the log file none
> > others.
> >
> > Can anyone tell me whats wrong or what to do?
> >
> > <?xml version="1.0" encoding="utf-8" ?>
> > <log4net>
> >  <appender name="FileAppender" type="log4net.Appender.FileAppender">
> >   <file value="ErroLog.log" />
> >   <appendToFile value="true" />
> >   <lockingModel type="log4net.Appender.FileAppender+MinimalLock" />
> >   <layout type="log4net.Layout.PatternLayout">
> >    <conversionPattern value="%d [%t] %c %x - %m%n" />
> >   </layout>
> >  </appender>
> >
> >  <root>
> >   <level value="WARN" />
> >   <appender-ref ref="FileAppender" />
> >  </root>
> > </log4net>
> > Thanks
> > Naeem Ullah Khan
> >
>
>


--
Naeem Ullah Khan

Mime
View raw message