logging-log4net-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Esterbrooks, Brette" <BGEsterbro...@landolakes.com>
Subject Re: Type int in ADOAppender.
Date Fri, 15 Jul 2005 14:39:45 GMT
I am just curious if you have resolved this issue? And if so how as I am

running into the same situation.
 
Thanks,
Brette
 

pato43 <pato43 <at> ig.com.br> writes:
 
> 
> Dear Friends, 
> 
>   I really tried several times to make my ADOApeender to accept a
parameter 
> as int, but did not work any time. 
> 
> The field in my database is an Int. My database is a sqlserver. 
> If i change the database type to string, works, when i back to Int,
doens't 
> work, and any error appears. 
> 
> This kind of configuration works ok.... 
> <param name="Parameter"> 
>    <param name="ParameterName" value=" <at> userID" /> 
>    <param name="DbType" value="String" /> 
>    <param name="Size" value="40" /> 
>    <param name="Layout" type="log4net.Layout.PatternLayout"> 
>       <param name="ConversionPattern" value="%x" /> 
>    </param> 
> </param> 
> 
> But what i should to do to work with an Int ? 
> I try to change the DbType to Int, Int32. 
> I try to remove the size parameter and mantain the Dbtype as string. 
> I try to remove the layout parameter... and much more... :)) 
> 
> Please, help me. I'm going to write my own database logger. 
> 
> Regards, 
> 
> Pietro. 
> 
 

 
 
Brette Esterbrooks
Land O'Lakes E-Business 
651-766-1436 
 

Mime
View raw message