logging-log4net-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: NAnt and Mono (was Re: Happy to help)
Date Sun, 11 Sep 2016 16:21:20 GMT
On 2016-09-11, Ryan Boggs wrote:

> On Sep 11, 2016 2:23 AM, "Stefan Bodewig" <bodewig@apache.org> wrote:

>> On 2016-09-09, Ryan Boggs wrote:

>>> Fyi - One thing i do know regarding NAnt, mono, and windows is that when
>>> they updated the installer for 4, they omitted the registry settings for
>>> the first couple of releases so NAnt couldn't find it.

>> I went back to 3.12.1 after your comment but NAnt 0.92 still doesn't
>> recognize Mono.

>> On Linux things aren't really any better as NAnt considers Mono 4.x as
>> "mono-4.5" framework and won't build anything at all as the framework is
>> not supported. And it really doesn't seem to find the compiler and
>> reference assemblies (that are likely not there, anyway) when I run Nant
>> with -t:mono-4.0

> What version of NAnt are you using?

0.92 downloaded from the project site.

,----
| WARNING: The runtime version supported by this application is unavailable.
| Using default runtime: v4.0.30319
| NAnt 0.92 (Build 0.92.4543.0; release; 09.06.2012)
`----

Stefan

Mime
View raw message