logging-log4net-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominik Psenner (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LOG4NET-178) Log4Net stops logging after appdomain recycle of ASP.NET2.0 application
Date Mon, 15 Jun 2015 19:40:00 GMT

    [ https://issues.apache.org/jira/browse/LOG4NET-178?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14586545#comment-14586545
] 

Dominik Psenner commented on LOG4NET-178:
-----------------------------------------

Glad to read people are working on this issue. I have no idea what causes Kamrans application
to fail. The RollingFileAppender is a major mess that I already tried to clean up with a rewrite
from scratch. Unfortunately it is not finished yet and won't be anytime soon because there
is so little sparetime. Kamran, given that you have written his own logging framework you
hopefully work out what's going on. Whatever the issues are you find, please feed them back
and contribute your ideas. Best would be a patch or concept that fixes or explains the issue.
Now that there is someone who can reproduce the symptoms I hope for the best.

> Log4Net stops logging after appdomain recycle of ASP.NET2.0 application
> -----------------------------------------------------------------------
>
>                 Key: LOG4NET-178
>                 URL: https://issues.apache.org/jira/browse/LOG4NET-178
>             Project: Log4net
>          Issue Type: Bug
>          Components: Appenders
>    Affects Versions: 1.2.10
>         Environment: Windows server 2003
>            Reporter: Richard Nijkamp
>            Assignee: Dominik Psenner
>             Fix For: 1.2.12
>
>
> Dear sir/madam,
>  We are using Log4Net 1.2.10. We encounter the problem that Log4net doesn't continue
logging after an event that triggers an appdomain recycle/restart.
>  In the global.asax we start the logging with:
>  private static readonly ILog log = LogManager.GetLogger(MethodBase.GetCurrentMethod().DeclaringType);
> Logging works flawless when the application is started for the first time. After sometime
it might occur that the appdomain gets recycled due to inactivity of the web application.
We use the following code in Application_end():
> log.Info("*** Application end ***");
> log4net.LogManager.Shutdown();
> After this function the application gets restarted and the Application_start() method
executes and writes new lines to the log. The problem is that the log4net doesn't write the
new lines after the restart. Could you explain why log4net might stop working after an appdomain
restart of an asp.net2.0 web application? If I want log4net to work properly again I need
to restart IIS manually.
>  Looking forward to your reply.
> Best regards,
> Richard Nijkamp



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message