logging-log4net-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominik Psenner (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (LOG4NET-449) RollingFileAppender is not working correctly.
Date Wed, 07 Jan 2015 20:46:35 GMT

     [ https://issues.apache.org/jira/browse/LOG4NET-449?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dominik Psenner closed LOG4NET-449.
-----------------------------------
    Resolution: Invalid
      Assignee: Dominik Psenner

Looks like your log4net is badly configured. If append is set to false, log4net will not append
logs to an existing logfile. Set the append flag to true and it should work. If this does
not resolve your problem, feel free to reopen this issue.

> RollingFileAppender is not working correctly.
> ---------------------------------------------
>
>                 Key: LOG4NET-449
>                 URL: https://issues.apache.org/jira/browse/LOG4NET-449
>             Project: Log4net
>          Issue Type: Bug
>          Components: Appenders
>    Affects Versions: 1.2.11
>         Environment: Circular logging is enabled through Log4net in Virtual directory
Service Environment.
>            Reporter: Priyabrata Baral
>            Assignee: Dominik Psenner
>
> We have one circulat logging enabled through Log4net. However we can see  there is a
discontinuity in logging(i.e: inbetween some of the logs not found).
> Also we can see logs are getting generated, however not getting appended correctly. And
we are getting below error in Log4net file:
> log4net:ERROR RollingFileAppender: INTERNAL ERROR. Append is False but OutputFile [G:\Program
Files\Optimal IdM\_TraceLogging\VISServer.log] already exists.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message