logging-log4net-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Bodewig (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (LOG4NET-423) The logs don’t appear working correctly. New logs are created at 12:00PM EST every day. This is in addition to the Recycle and new log creation at 12:00 AM EST. We are losing log entries from 12:00AM to 11:59AM.
Date Thu, 20 Feb 2014 13:40:21 GMT

    [ https://issues.apache.org/jira/browse/LOG4NET-423?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13906955#comment-13906955
] 

Stefan Bodewig edited comment on LOG4NET-423 at 2/20/14 1:39 PM:
-----------------------------------------------------------------

Vaishali, this is log4net's bug tracker, not a support forum.  I'd expect you'd get more faster
and better responses if you used the user mailing list instead - far more people will be reading
your question there than inside this tracker.

As for the problem you face I can only say there are plenty of open bug reports against RollingFileAppender
in particular once you start mixing rolling based on size and date - as you do.  I would recommend
you stick with one of the two roling strategies.


was (Author: bodewig):
Vaishali, this is log4net's bug tracker, not a support forum.  I'd assume you'd get more faster
and better responses if you used the user mailing list instead - far more people will be reading
your question there than inside this tracker.

As for the problem you face I can only say there are plenty of open bug reports against RollingFileAppender
in particular once you start mixing rolling based on size and date - as you do.  I would recommend
you stick with one of the two roling strategies.

> The logs don’t appear working correctly.   New logs are created at 12:00PM EST every
day.  This is in addition to the Recycle and new log creation at 12:00 AM EST.   We are losing
log entries from 12:00AM to 11:59AM. 
> -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: LOG4NET-423
>                 URL: https://issues.apache.org/jira/browse/LOG4NET-423
>             Project: Log4net
>          Issue Type: Bug
>          Components: Appenders
>            Reporter: Vaishali Meshram
>              Labels: rolling
>
> <log4net debug="true">
> <appender name="MyRollingFile" type="log4net.Appender.RollingFileAppender">
> <param name="File" value="Logs\\Filename.xls" />
> <param name="AppendToFile" value="true" />
> <param name="MaximumFileSize" value="20MB" />
> <param name="MaxSizeRollBackups" value="20" />
> <rollingStyle value="Composite" />
> <datePattern value="yyyyMMdd" />
> <staticLogFileName value="false" />
> <layout type="log4net.Layout.PatternLayout">
> <header value="DateTime\tType\tUserID\tBusinessUnitID\tOperatingUnitID\tUser City\tUser
State\tUser Country\tServer Name\tPage Name\tTime ms\tTicket\tMethod\tError\tError Details\tAddtional
Error\tAddtional Error Details\tQuery Filters\tDuration Time ms\n" />
> <param name="ConversionPattern" value="%d&#x9;%-5p&#x9;%m%n" />
> </layout>
> </appender>
> <root>
> <!-- Logging Level: ALL, DEBUG, INFO, WARN, ERROR, FATAL -->
> <!--<level value="ERROR" />
> <level value="INFO" />-->
> <level value="ALL"/>
> <appender-ref ref="MyRollingFile" />
> </root>
> </log4net>
> Above is my log4net configuration values.. My issue is that when I am trying to rolled
file. the files are in this format filename.xls20140219, filename.xls20140219.1,........filename.xls20140219.20.
It is working fine till 12 AM. But its lost some log entries in between 12 AM to 11.59 AM.
Please tell me what is the issue with me. Anything wrong in config file.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message