logging-log4net-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mat Arge (JIRA)" <j...@apache.org>
Subject [jira] [Created] (LOG4NET-420) Destructor of class called upon invoking XmlConfigurator.Configure
Date Tue, 28 Jan 2014 11:38:38 GMT
Mat Arge created LOG4NET-420:
--------------------------------

             Summary: Destructor of class called upon invoking XmlConfigurator.Configure
                 Key: LOG4NET-420
                 URL: https://issues.apache.org/jira/browse/LOG4NET-420
             Project: Log4net
          Issue Type: Bug
          Components: Core
    Affects Versions: 1.2.13, 1.2.10
         Environment: Linux (openSuse 12.2 i586), Mono 2.10.9
            Reporter: Mat Arge


If I run XmlConfigurator.Configure on an XML File after an instance of some class has been
created, the destructor of that class is called for some reason. Here is my test code:

using System;
	    
	    public class Test 
	    {

	      ~Test()
	      {
		Console.WriteLine("Test object finalized.");
	      }
	    }

public static class M
{
public static void Main()
  {
    Console.WriteLine("Start");
    Test test = new Test();
    Console.WriteLine("configuring");
    log4net.Config.XmlConfigurator.Configure(new System.IO.FileInfo("LogConfiguration.xml"));
    Console.WriteLine("End");
  }
}

Running this yields the output: 

Start
configuring
Test object finalized.
End

I'm not really sure, if this is a bug in log4net or in mono



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message