logging-log4net-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul H. Harder II (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LOG4NET-287) Wrong line number for log
Date Thu, 09 Jan 2014 22:45:51 GMT

    [ https://issues.apache.org/jira/browse/LOG4NET-287?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13867213#comment-13867213
] 

Paul H. Harder II commented on LOG4NET-287:
-------------------------------------------

I seem to have the same issue. My DLL and PDB have matching time stamps in the build directory
(release branch) and they both match the time stamps in the directory where the Windows installer
placed files during installation. When I run my Windows service, line numbers recorded by
log4net are 0, 1, 2, or 3 lines off from what they should be. When I build my DLL in debug
mode and run it from my test program (a console application, not a Windows service), I get
perfect line numbers.  Windows Explorer has been searching my entire hard disk for a PDB file
of the same name for about an hour now, and it has not turned up any except those in the project
directories and the one in the installation directory. I do not think that the problem is
a mismatch between DLL and PDB files.

> Wrong line number for log 
> --------------------------
>
>                 Key: LOG4NET-287
>                 URL: https://issues.apache.org/jira/browse/LOG4NET-287
>             Project: Log4net
>          Issue Type: Bug
>          Components: Appenders
>    Affects Versions: 1.2.10
>         Environment: Windows XP, .NET 3.5, Microsot Virsual Studio
>            Reporter: Shuang yin Liu
>
> In our project, we use the line number function of log4net. Many of log line numbers
are 1 line after the actual line. Other are 2 or 3 lines gap(when exception log is written
or at the end of the main application).



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message