logging-log4net-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominik Psenner (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (LOG4NET-387) Mysterious characters in the log file
Date Tue, 13 Aug 2013 06:10:48 GMT

    [ https://issues.apache.org/jira/browse/LOG4NET-387?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13737879#comment-13737879
] 

Dominik Psenner edited comment on LOG4NET-387 at 8/13/13 6:10 AM:
------------------------------------------------------------------

I can imagine nothing in log4net that could cause such an issue. To me it would look much
more like an issue with the filesystem (immanent hard drive failure) or the application is
logging binary content. If one tries to open a binary file (i.e. a xsl file) it will look
much alike what you see there.

Anyway, we need much more information than what you have provided in order to investigate
further. Do you have a sample application for us that reproduces the issue?
                
      was (Author: nachbarslumpi):
    I can imagine nothing in log4net that could cause such an issue. To me it would look much
more like an issue with the filesystem (immanent hard drive failure) or the application is
logging binary content. If one tries to open a binary file (i.e. a xsl file) it will look
much alike what you see there.

Anyway, we would need much more information than what you have provided in order to investigate
further. Do you have a sample application for us that reproduces the issue?
                  
> Mysterious characters in the log file
> -------------------------------------
>
>                 Key: LOG4NET-387
>                 URL: https://issues.apache.org/jira/browse/LOG4NET-387
>             Project: Log4net
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 1.2.10
>         Environment: Windows XP, .Net 2.0 Framework, Windows Service Application
>            Reporter: Baha
>            Priority: Blocker
>              Labels: bug
>             Fix For: 1.2.10
>
>
> We have a windows service application in production. This windows service is logging
greatly with no issues, but sometimes it starts logging mysterious characters like in this
screenshot:
> https://files.secureserver.net/0sq7H3khXnoq67
> To fix this, we clean the log file, and restart the windows service again, but in this
way, we are loosing most of the logs (specially the exception/error fired by the windows service).
> Any idea on this will be greatly appreciated.
> Baha Ashour,
> RFID Enabled Solutions
> baha@resrfid.com 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message