logging-log4net-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominik Psenner (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LOG4NET-339) log4net.Appender.EventLogAppende cause our application to stuck.
Date Thu, 06 Jun 2013 06:48:20 GMT

    [ https://issues.apache.org/jira/browse/LOG4NET-339?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13676765#comment-13676765
] 

Dominik Psenner commented on LOG4NET-339:
-----------------------------------------

Actually the stack trace does not mention log4net. Some objects of log4net are in the memory
dump, but that's nothing to wonder about. From the comment:

"we are appending the events 04ACEEE0 00f3ba38 log4net.Appender.EventLogAppender and we are
waiting on it (clr!WaitForMultipleObjectsEx_SO_TOLERANT+0x56 --wait). 
The issue seems to be coming from log4net."

I'm interpreting it like this: "log4net appends events to the windows event log but somehow
that event log is waiting for something". Basically, yes, the issue comes from log4net. But
log4net is doing a system call and that call gets stuck. It smells like a deadlock deep inside
the eventlog. I don't know for sure and I may be wrong, but to me it does not look like a
log4net issue.

Anyway, what's the current state of the problem? The last update was about a year ago. Were
you able to work out a solution, workaround or maybe the reason why this happens?
                
> log4net.Appender.EventLogAppende cause our application to stuck. 
> -----------------------------------------------------------------
>
>                 Key: LOG4NET-339
>                 URL: https://issues.apache.org/jira/browse/LOG4NET-339
>             Project: Log4net
>          Issue Type: Bug
>          Components: Appenders
>    Affects Versions: 1.2.10
>         Environment: Windows Server 2008 R2 SP1
>            Reporter: Yaron Yeshaya
>
> Randomly one of our COM Service (.Net 4.0 Windows service that exposes com interface)
stop processing com calls. We spoke with Microsoft and sent the the application dump file.
> Microsoft claims that from the dump it looks like log4net issue: "we are appending the
events 04ACEEE0 00f3ba38 log4net.Appender.EventLogAppender and we are waiting on it (clr!WaitForMultipleObjectsEx_SO_TOLERANT+0x56
 --wait).
> The issue seems to be coming from log4net."
> Did you encountered such an issue?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message