logging-log4net-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chirag Chandani (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (LOG4NET-366) log4NET DCOM registration not working
Date Wed, 16 Jan 2013 13:36:12 GMT

     [ https://issues.apache.org/jira/browse/LOG4NET-366?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chirag Chandani updated LOG4NET-366:
------------------------------------

    Description: 
We have a classic ASP application running on IIS 7.5 on Windows Server 2008 R2

There is a DLL build in the code to use Log4NET logging with an ASP application.

So, In order for log4net to work on traditional ASP a DCOM object is used, which is  "SuperMam.Logs2ASP.DLL"

The following is done for the registration:

1. REGASM with the following command:
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\regasm "SuperMam.Logs2ASP.dll" /tlb /codebase

2. Within Component Services, A new COM+ Application is created for Logs2ASP (running under
user NETWORK_SERVICE) and inside this application create the component SuperMam.Logs2ASP by
choosing it from the registered components.

3. Now that the COM+ Application is configurable, The settings are changed by un-checking
the check box for “enforce access checks for this application”

4. Then DCOMCNFG is opened on 32 bit by using mmc -32 and adding the Component Services add-in,
to make sure it recognizes the new application.

But the problem we are facing is that Log4NET is never registered properly and due to which
the application returns a HTTP 500

Please help in solving the situation or suggesting the error

Thanks

  was:
We have a classic ASP application running on IIS 7.5 on Windows Server 2008 R2

There is a DLL build in the code to use Log4NET logging with an ASP application.

So, In order for log4net to work on traditional ASP a DCOM object is used, which is  "SuperMam.Logs2ASP.DLL"

The following is done for the registration:

1. REGASM with the following command:
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\regasm "SuperMam.Logs2ASP.dll" /tlb /codebase

2. Within Component Services, A new COM+ Application is created for Logs2ASP (running under
user NETWORK_SERVICE) and inside this application create the component SuperMam.Logs2ASP by
choosing it from the registered components.

3. Now that the COM+ Application is configurable, The settings are changed by un-checking
the check box for “enforce access checks for this application”

4. Then DCOMCNFG is opened on 32 bit by using mmc -32 and adding the Component Services add-in,
to make sure he recognizes the new application.

But the problem we are facing is that Log4NET is never registered properly and due to which
the application returns a HTTP 500

Please help in solving the situation or suggesting the error

Thanks

    
> log4NET DCOM registration not working
> -------------------------------------
>
>                 Key: LOG4NET-366
>                 URL: https://issues.apache.org/jira/browse/LOG4NET-366
>             Project: Log4net
>          Issue Type: Task
>          Components: Builds
>         Environment: OS: Windows Server 2008 R2
> Application hosting server: IIS 7.5
>            Reporter: Chirag Chandani
>
> We have a classic ASP application running on IIS 7.5 on Windows Server 2008 R2
> There is a DLL build in the code to use Log4NET logging with an ASP application.
> So, In order for log4net to work on traditional ASP a DCOM object is used, which is 
"SuperMam.Logs2ASP.DLL"
> The following is done for the registration:
> 1. REGASM with the following command:
> C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\regasm "SuperMam.Logs2ASP.dll" /tlb /codebase
> 2. Within Component Services, A new COM+ Application is created for Logs2ASP (running
under user NETWORK_SERVICE) and inside this application create the component SuperMam.Logs2ASP
by choosing it from the registered components.
> 3. Now that the COM+ Application is configurable, The settings are changed by un-checking
the check box for “enforce access checks for this application”
> 4. Then DCOMCNFG is opened on 32 bit by using mmc -32 and adding the Component Services
add-in, to make sure it recognizes the new application.
> But the problem we are facing is that Log4NET is never registered properly and due to
which the application returns a HTTP 500
> Please help in solving the situation or suggesting the error
> Thanks

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message