logging-log4net-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominik Psenner (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LOG4NET-178) Log4Net stops logging after appdomain recycle of aps.net2.0 application
Date Tue, 27 Nov 2012 09:57:59 GMT

    [ https://issues.apache.org/jira/browse/LOG4NET-178?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13504496#comment-13504496
] 

Dominik Psenner commented on LOG4NET-178:
-----------------------------------------

So the general consensus is that the issue is:

1] IIS (7.5?) specific
2] a timing problem caused by misplaced shutdown / start events
3] solvable with a "manual" reconfiguration of log4net in the right spot
4] not solvable in log4net itself since log4net has to handle events when they are raised

If these conditions are met I would close this issue with resolution "invalid" and add a new
FAQ entry at http://logging.apache.org/log4net/release/faq.html describing the issue and a
rather detailed description how it can be fixed. To be able to do that, would one of you guys
please write down an answer to the question:

"Why does my IIS hosted web application stop logging after some time?"
                
> Log4Net stops logging after appdomain recycle of aps.net2.0 application
> -----------------------------------------------------------------------
>
>                 Key: LOG4NET-178
>                 URL: https://issues.apache.org/jira/browse/LOG4NET-178
>             Project: Log4net
>          Issue Type: Bug
>          Components: Appenders
>    Affects Versions: 1.2.10
>         Environment: Windows server 2003
>            Reporter: Richard Nijkamp
>             Fix For: 1.2 Maintenance Release
>
>
> Dear sir/madam,
>  We are using Log4Net 1.2.10. We encounter the problem that Log4net doesn't continue
logging after an event that triggers an appdomain recycle/restart.
>  In the global.asax we start the logging with:
>  private static readonly ILog log = LogManager.GetLogger(MethodBase.GetCurrentMethod().DeclaringType);
> Logging works flawless when the application is started for the first time. After sometime
it might occur that the appdomain gets recycled due to inactivity of the web application.
We use the following code in Application_end():
> log.Info("*** Application end ***");
> log4net.LogManager.Shutdown();
> After this function the application gets restarted and the Application_start() method
executes and writes new lines to the log. The problem is that the log4net doesn't write the
new lines after the restart. Could you explain why log4net might stop working after an appdomain
restart of an asp.net2.0 web application? If I want log4net to work properly again I need
to restart IIS manually.
>  Looking forward to your reply.
> Best regards,
> Richard Nijkamp

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message