logging-log4net-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roy Chastain" <...@roychastain.org>
Subject RE: ADO.NET Appender and FX 4.0
Date Sat, 20 Aug 2011 17:54:44 GMT
>I should add that NAnt.exe.config contains

>      <NetFx40_LegacySecurityPolicy enabled="true"/>

>and seems to need it.  This may complicate things even further.

See this http://msdn.microsoft.com/en-us/library/dd409253.aspx

My gut says that this setting is a BAD thing.
1) - It is a RUNTIME not COMPILE time setting.  If code for legacy
security being enabled, then anyone that uses log4Net will have to
specify legacy security and that is just not going to work very well.
2) - It should only be set for code that explicitly defines a CAS
policy.3) - From reading more MS documents, this setting appears to be a
"migration setting" and we should not plan on running that way
indefinitely.

I think we are already in too deep to make a 4.0 target for the 1.2.11
release because we are going to have to
1) - Understand the new (non) CAS security model
2) - Make code changes to support it

Now, that I have written all of this, I assume NAnt.exe.config is the
config file for NAnt, not for what it builds.  If so, then this setting
is simply telling the NAnt runtime to run with legacy security and that
is not even meaningful unless NAnt is targeted to 4.0

----------------------------------------------------------------------
Roy Chastain





Mime
View raw message