logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tommmmmm <tommm...@gmail.com>
Subject Re: Log4J doesn't work at all
Date Tue, 10 Apr 2012 19:29:51 GMT
My debug for log4j:
log4j: Trying to find [log4j.xml] using context classloader
sun.misc.Launcher$AppClassLoader@56e88e24.
log4j: Trying to find [log4j.xml] using
sun.misc.Launcher$AppClassLoader@56e88e24 class loader.
log4j: Trying to find [log4j.xml] using ClassLoader.getSystemResource().
log4j: Trying to find [log4j.properties] using context classloader
sun.misc.Launcher$AppClassLoader@56e88e24.
log4j: Trying to find [log4j.properties] using
sun.misc.Launcher$AppClassLoader@56e88e24 class loader.
log4j: Trying to find [log4j.properties] using
ClassLoader.getSystemResource().
log4j: Could not find resource: [null].
log4j: Parsing for [root] with value=[DEBUG, stdout].
log4j: Level token is [DEBUG].
log4j: Category root set to DEBUG
log4j: Parsing appender named "stdout".
log4j: Parsing layout options for "stdout".
log4j: Setting property [conversionPattern] to [%5p [%c] %m%n].
log4j: End of parsing for "stdout".
log4j: Parsed "stdout" options.
log4j: Parsing for [org.apache.http.wire] with value=[DEBUG].
log4j: Level token is [DEBUG].
log4j: Category org.apache.http.wire set to DEBUG
log4j: Handling log4j.additivity.org.apache.http.wire=[null]
log4j: Parsing for [org.apache.http] with value=[DEBUG].
log4j: Level token is [DEBUG].
log4j: Category org.apache.http set to DEBUG
log4j: Handling log4j.additivity.org.apache.http=[null]
log4j: Parsing for [jobManager] with value=[DEBUG].
log4j: Level token is [DEBUG].
log4j: Category jobManager set to DEBUG
log4j: Handling log4j.additivity.jobManager=[null]
log4j: Finished configuring.

My output for
System.out.println(httpClient.getClass().getClassLoader().getResource("log4j.properties"));
is: null

It seems the httpClient is not using the logger properties I specified. But
I thought that's why there was this line:
log4j.logger.org.apache.http=DEBUG in the first place.

I am so confused. Any hints?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message