logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Günther, Rene - Innflow AG" <rene.guent...@innflow.com>
Subject AW: WG: Only partial logging with log.debug
Date Sun, 02 Aug 2009 13:17:07 GMT
I just solved it. I was just too dumb to see the error in my code.

If anyone is interested: I was logging the same information twice: at the beginning of the
loop and at the end of the loop. Depending on some variable I had a "continue;" statement
in the middle. Obviously it run the "continue;" for every step. The log.debug calls after
the continue never happened. I just saw the information that has been logged and I thought
that was because of my log.debug call at the end of the loop. No, it was because the log.debug
call at the beginning of the loop.

Thanks anyway
Rene

-----Ursprüngliche Nachricht-----
Von: Simon Gibbs [mailto:simon.gibbs@cantorva.com] 
Gesendet: Sonntag, 2. August 2009 15:05
An: Log4J Users List
Betreff: Re: WG: Only partial logging with log.debug

Günther, Rene - Innflow AG wrote:
> The first appends a line in my logfile, the second call of debug 
> doesn’t append anything.
>
> Any idea where to look at?
>   

What does the third statement do?

If this is the last statement you are expecting and depending on your appender it could be
buffered. Try adjusting buffers.

Simon



---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message