logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Stauffer" <stauffer.ja...@gmail.com>
Subject Re: dependency on old log4j from an included jar
Date Mon, 06 Aug 2007 12:18:17 GMT
Using separate classloaders might work.

On 8/6/07, Nicholas Hogg <Nicholas.Hogg@kesoftware.com> wrote:
> Hi,
>
> This is my first post to this list - I have the following problem:
>
> For a project I am working on I am required to use a 3rd party jar.
> This jar uses log4j-1.1.3, where as my project uses log4j-1.2.13.  As
> I'm sure you are aware there are classes (Category) in 1.1.3 that are
> not backwards compatible in later releases, hence I get
> NoClassDefinition exceptions depending on what version of log4j gets
> loaded first.
>
> I can rule out the possibility of the 3rd party updating their code to
> use a later version of log4j.  I also have no choice but to use their
> jar, as it provides the API into the 3rd party's software.
>
> Is there any way I can continue to use a later log4j in my code while
> accessing the 3rd parties libraries?  I'm not willing to "downgrade" my
> log4j to their version.  If there is no solution here I will probably
> just replace log4j in my code with the standard java logging but that
> will be really annoying!
>
> Many thanks,
> Nick
>
> --
> Nicholas Hogg
> KE Software (Australia)
> www.kesoftware.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
> For additional commands, e-mail: log4j-user-help@logging.apache.org
>
>


-- 
James Stauffer        http://www.geocities.com/stauffer_james/
Are you good? Take the test at http://www.livingwaters.com/good/

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message