logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Curt Arnold <carn...@apache.org>
Subject Re: IO error while logging
Date Mon, 14 Aug 2006 18:40:54 GMT

On Aug 14, 2006, at 10:22 AM, Mike Baranczak wrote:

> I'm seeing an intermittent error on one of our jboss servers. Every  
> once in a while, something happens to the logging system, and every  
> attempt to write to the log causes an exception (see below), which  
> of course is of major concern to us.
>
> So far, this is only happening on one box. I'm trying to narrow it  
> down some more, but so far I don't have a lot to go on. Any  
> suggestions would be most welcome.
>
>
>
> JBoss 4.0.1 with log4j 1.2.8
> Java 1.5.0_05 on Linux
>
>
> java.lang.IllegalStateException: Current state = FLUSHED, new state  
> = CODING
>         at  
> java.nio.charset.CharsetEncoder.throwIllegalStateException 
> (CharsetEncoder.java:941)
>         at java.nio.charset.CharsetEncoder.encode 
> (CharsetEncoder.java:537)
>

A possible work around may be to explicitly specify the encoding for  
the appender or explicitly state the encoding for the JVM.  Is the  
encoding used on the one box in question different than the other  
boxes?  I'd suggest trying UTF-16 as the encoding since that should  
have the simplest encoder.  Then maybe UTF-8.

If you do a search on  
java.nio.charset.CharsetEncoder.throwIllegalStateException, you will  
find several issues in bugs.sun.com.  Unclear if they were fixed by  
1.5.0_05.

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message