logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raúl Santiago <mi...@virtualsw.com>
Subject ZeroConfigHubAppender error
Date Tue, 20 Jun 2006 08:09:27 GMT
I've been using log4j in a desktop app for a while. I tried to use 
Chainsaw v2 to watch the log while the app is being tested, from another 
computer, using ZeroConfSocketHubAppender.
I made all the necessary steps to add required jar files and modified 
log4j.xml config file to use the appender.

My app starts OK, takes a few seconds to make "the network magic", and 
Chainsaw v2 finds my app in the network. When I try to connect to the 
log, in the app side I get this exception:

Exception in thread "Thread-0" java.lang.NoSuchMethodError: 
org.apache.log4j.spi.ComponentBase.access$701(Lorg/apache/log4j/net/SocketHubAppender;)Lorg/apache/log4j/ULogger;
    at 
org.apache.log4j.net.SocketHubAppender$ServerMonitor.run(SocketHubAppender.java:392)
    at java.lang.Thread.run(Thread.java:595)

I'm using Chainsaw v2 (version 2006-03-02 (SVN tag 'release_20060302')), 
and the jar libraries linked from the Chainsaw web (log4j ZeroConf 
extension and JmDNS bundle).
I've tried with log4j 1.2.13 and 1.3 alpha8. None of them has the method 
"access" implemented in "ComponentBase" class. I tried with 
"ComponentBase" from the SVN repository, and the method wasn't there 
neither.

A Google search was not of great help: at least, two other calls to that 
method seem to cause the same exception from other classes, but no 
solution found.

Any hint on what is going wrong?
Thanks in advance.

-- 

Raúl Santiago Gómez
Virtual Software S.L.
mijac@virtualsw.com

"El programador crea aplicaciones a prueba de tontos; Dios crea tontos a prueba de programadores"


---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message