logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: How to get log4j to work with commons-logging in web service app?
Date Tue, 28 Mar 2006 03:12:30 GMT

Put the config file in the default package.  Log4j will pick it up.

Jake

At 08:13 PM 3/27/2006, you wrote:
 >I'm not sure if this is a log4j or commons-logging issue but my problem
 >is that...
 >
 >
 >
 >I have an application (local web service) that uses Jetty and AXIS.  We
 >just started using commons-logging and we want to configure it to use
 >log4j.
 >
 >
 >
 >>From the online docs I gathered that to configure commons-logging I
 >really just had to make sure that log4j was in my classpath; which I did
 >and through our IDE debugger and I see the following message which, I
 >think, means that commons-logging found log4j.  (Since this is through
 >the IDE it is the simple case, i.e. no Jetty and AXIS yet.
 >
 >
 >
 >log4j:WARN No appenders could be found for logger (Logger_Name).
 >
 >log4j:WARN Please initialize the log4j system properly.
 >
 >
 >
 >However, when I run the application (fire up Jetty/AXIS/App) I get NO
 >logging.  I don't know if this is a log4j or commons-logging issue at
 >runtime as I see nothing.
 >
 >
 >
 >Do I need any commons-logging property/config file?  If so, where does
 >it go?
 >
 >
 >
 >Where do I put the log4j.properties file?  I haven't used log4j much,
 >but I think it has been found in the current directory before; now this
 >is not working.  I have also put it in the classpath with no success.
 >
 >
 >
 >Any ideas?  How can I debug to see where the failure is?
 >
 >
 >
 >Thanks.
 >
 >
 >
 >-Dave
 >
 >


---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message