logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Deboy" <sde...@comotivsystems.com>
Subject RE: chainsaw timestampFormat and relative dates
Date Tue, 14 Feb 2006 18:39:26 GMT
LogFilePatternReceiver uses SimpleDateFormat.  If you don't specify a year with SimpleDateFormat,
it assumes 1970.

Scott Deboy
COMOTIV SYSTEMS
111 SW Columbia Street Ste. 950
Portland, OR  97201

Telephone:      503.224.7496
Cell:           503.997.1367
Fax:            503.222.0185

sdeboy@comotivsystems.com

www.comotivsystems.com



-----Original Message-----
From: Jacob Kjome [mailto:hoju@visi.com]
Sent: Tue 2/14/2006 10:23 AM
To: Log4J Users List
Subject: Re: chainsaw timestampFormat and relative dates
 

Ok, I should have verified first.  I found out that the config file is
specifying a custom date format.  Our official config file has the ISO8601
format, but that hadn't been put in place on the appserver.  I was just
assuming that the ISO8601 format was what I was seeing.  Whoops.  I thought
that would be odd for an ISO format.  I suppose there probably isn't a way to
specify a relative date where the year is assumed to be the current year and
not 1970.  If I'm wrong, someone please speak up.  Otherwise, I don't think it
will be an issue for me any longer anyway.

I still am wondering about the SFTP stuff I mentioned, so if anyone has anything
to say about that, it would be appreciated.

Jake

Quoting Jacob Kjome <hoju@visi.com>:

>
>
> We have a log4j configuration with a file appender having the conversion
> pattern....
>
> %-14d{ISO8601} %-5p %c{3} - %m%n
>
> This results in lines such as...
>
> 13/02 14:05:06 DEBUG ui.actions.MyAction - Some message
>
>
> My chainsaw config has the following for timestampFormat...
>
> dd/MM HH:mm:ss
>
> This works, as it matches the timestamp provided by the ISO8601 date (at
> least
> chainsaw seems to accept it as valid).  However, it results in the year being
> displayed as 1970.
>
> So, how do I get this to to assume that the unstated year is the current
> year,
> not 1970?
>
> Also, unrelated, what version of JSCH do you use when using the sftp://
> protocol
> via VFS?  I've now been able to connect via ftp:// using my
> username/password,
> but not via SFTP.  I've verified that I can connect via SFTP using FileZilla.
> Just wondering if you had any insight?  I've also tried this outside of
> Chainsaw (using the <vfs:copy> Ant task) and get the same result.  Then
> again,
> I'm using the same versions of VFS and JSCH there as I do in Chainsaw.  Just
> wondering if there is a magic combination of versions that works?  Otherwise,
> I
> guess I'll take this question to the commons list.
>
> later,
>
> Jake
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
> For additional commands, e-mail: log4j-user-help@logging.apache.org
>




---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org




Mime
View raw message