logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: Chainsaw: release_20060202 updated
Date Thu, 02 Feb 2006 20:49:30 GMT

Update:

If I use the .jnlp file at
http://logging.apache.org/log4j/docs/webstart/chainsaw/upload/webstart-bundle-20060202/,
it works just fine... well, at least it installs.  I'm still seeing some
issues...

1. "error creating log panel" in the chainaw-log tab...

java.lang.IllegalArgumentException: Identifier not found
	at javax.swing.table.DefaultTableColumnModel.getColumnIndex(Unknown Source)
	at javax.swing.JTable.getColumn(Unknown Source)
	at org.apache.log4j.chainsaw.LogPanel$28.newKeyAdded(LogPanel.java:841)
	at
org.apache.log4j.chainsaw.ChainsawCyclicBufferTableModel.fireNewKeyColumnAdded(ChainsawCyclicBufferTableModel.java:548)
	at
org.apache.log4j.chainsaw.ChainsawCyclicBufferTableModel.isAddRow(ChainsawCyclicBufferTableModel.java:489)
	at org.apache.log4j.chainsaw.LogPanel.receiveEventBatch(LogPanel.java:1386)
	at org.apache.log4j.chainsaw.LogUI.buildLogPanel(LogUI.java:1834)
	at org.apache.log4j.chainsaw.LogUI.access$3(LogUI.java:1770)
	at
org.apache.log4j.chainsaw.LogUI$NewTabEventBatchReceiver.receiveEventBatch(LogUI.java:1953)
	at
org.apache.log4j.chainsaw.ChainsawAppenderHandler$WorkQueue$WorkerThread.dispatchEventBatch(ChainsawAppenderHandler.java:342)
	at
org.apache.log4j.chainsaw.ChainsawAppenderHandler$WorkQueue$WorkerThread.run(ChainsawAppenderHandler.java:298)


2.  Using my LogFilePatternReceiver config, which used to work fine, to view
files on my local file system, it only shows only the first line of the file
where the same config used to show all the lines of the file in the previous
webstart version.  Here's my config followed by a sample log file line (of
which there a sevaral hundred existing, but only the first one displays in
Chainsaw ATM)...

    <plugin name="LogFileReceiver1"
class="org.apache.log4j.varia.LogFilePatternReceiver">
        <param name="fileURL"
value="file:///C:/bea/user_projects/domains/mydomain/config/logs/myserver-main.log"/>
        <param name="timestampFormat" value="yyyy-MM-dd HH:mm:ss,SSS"/>
        <param name="logFormat" value="TIMESTAMP LEVEL LOGGER - MESSAGE"/>
        <param name="name" value="MainLog"/>
        <param name="tailing" value="true"/>
    </plugin>

2005-12-19 16:21:53,471 INFO  model.codetable.CodeTableServiceImpl - Reading
CodeTable -: CompanyCode


3.  Although I don't get the classloader issues I used to get with the old
webstart version, it still can't seem to connect.  It just says it can't look
up the file and tries again every 10 seconds.  I haven't yet verified whether I
can use the VFS API to look up the file myself, but I can get to the file by
using a a GUI SFTP client to browse to the file using the same path defined in
my config.  Here's the config below (with the details changed to protect the
innocent)...

    <plugin name="VFSReceiver"
class="org.apache.log4j.chainsaw.vfs.VFSLogFilePatternReceiver">
        <param name="fileURL"
value="sftp://login:pass@myserver.com/path/to/logs/main.log"/>
        <param name="timestampFormat" value="yyyy-MM-d HH:mm:ss,SSS"/>
        <param name="logFormat" value="TIMESTAMP LEVEL LOGGER - MESSAGE"/>
        <param name="filterExpression" value="LEVEL > WARN"/>
        <param name="name" value="MyServer"/>
        <param name="tailing" value="true"/>
    </plugin>

One issue I might have is that my real password has a "?" in it.  I tried both
"?" itself and the URL escaped version "%3F".  I get no difference.  I also
tried it with and without specifying the port (22).  I'm using VFS-RC7 or later
(I can't remember whether I built it myself or not?).  Not sure what to make of
this.  If it works for you, then I wouldn't worry about this too much until I
can verify whether I can get VFS to find the file directly using the VFS API. 
I'll let you know what I find.


Jake


Quoting Jacob Kjome <hoju@visi.com>:

>
> Hi Paul,
>
> I get the following error when trying to install via webstart...
>
> JNLPException[category: Download Error : Exception: java.io.IOException: HTTP
> response 404 : LaunchDesc: null ]
> 	at com.sun.javaws.cache.DownloadProtocol.doDownload(Unknown Source)
> 	at com.sun.javaws.cache.DownloadProtocol.getDownloadSize(Unknown Source)
> 	at com.sun.javaws.LaunchDownload.downloadJarFiles(Unknown Source)
> 	at com.sun.javaws.LaunchDownload.downloadEagerorAll(Unknown Source)
> 	at com.sun.javaws.Launcher.downloadResources(Unknown Source)
> 	at com.sun.javaws.Launcher.handleApplicationDesc(Unknown Source)
> 	at com.sun.javaws.Launcher.handleLaunchFile(Unknown Source)
> 	at com.sun.javaws.Launcher.run(Unknown Source)
> 	at java.lang.Thread.run(Unknown Source)
>
>
> I pulled up the webstart console and removed the existing install that I had,
> since it pointed to the temporary location.  I even went into preferences and
> deleted all files in the cache.  Then, I went to the web page to launch
> Chainsaw via webstart.  That's when webstart reported the error above.  Looks
> like something's not quite right.
>
> Jake
>
> Quoting Paul Smith <psmith@aconex.com>:
>
> > Latest 'release' bundle (alpha) of Chainsaw is now available.
> >
> > Webstart version should auto-update, OSX and DOS/Unix version
> > available from:
> >
> > http://logging.apache.org/log4j/docs/chainsaw.html
> >
> > Comments appreciated, a new build process has been put in place, so
> > there could be a couple of gremlins there, please report anything
> > that you find.
> >
> > cheers,
> >
> > Paul Smith
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
> > For additional commands, e-mail: log4j-user-help@logging.apache.org
> >
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
> For additional commands, e-mail: log4j-user-help@logging.apache.org
>




---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-user-help@logging.apache.org


Mime
View raw message