logging-log4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pramodh Peddi" <ppe...@IMPRIVATA.com>
Subject RE: SyslogAppender not working
Date Thu, 02 Dec 2004 15:49:35 GMT
Hi,

I added the syslogApp.activateOptions() line, but still does not work.

There are other appenders (RollingFileAppender) working within the same
application, but SyslogAppender bails on me. Other appenders does not
have syslogApp.activateOptions() and works however.

 

Are there any other ideas? I appreciate the help.

 

Pramodh.

 

 

Pramodh Peddi

 

Software Engineer

 

v 781-674-2738

 

f  781-674-2760

 

www.imprivata.com

 

 

 

People are talking about OneSign:

 

"We were spending 35% of our IT time on password-related issues, says
Paula Chesbrough, CIO of Eagle Bank in Everett, Mass. "We've reduced
that workload to 10%."  Network World, 8/9/04

 

 

 

"Imprivata Quells Management Burdens"

 

CRN, 8/9/04

 

-----Original Message-----
From: Paul Smith [mailto:psmith@aconex.com] 
Sent: Wednesday, December 01, 2004 6:42 PM
To: Log4J Users List
Subject: Re: SyslogAppender not working

 

if you're adding this programatically, I'd suggest not to forget to
call:

 

syslogApp.activateOptions();

 

this goes for all Appenders really.

 

cheers,

 

Paul Smith

 

Pramodh Peddi wrote:

 

>Hi,

> 

>I am not experienced enough in SyslogAppender, because this is the
first

>time I am using it. I am trying to get the basic functionality working.

>I am running the application in a Linux machine (Suse).

> 

> 

> 

>This is the code I have:

> 

>***********************code**********************

> 

>mySyslogger = (SystemLog)Logger.getLogger("sso1", myFactory);

> 

> 

> 

>SyslogAppender syslogApp = new SyslogAppender(layout, "localhost",

>org.apache.log4j.net.SyslogAppender.LOG_USER);

> 

> 

> 

>addAppender(syslogApp);

> 

> 

> 

>mySyslogger.debug(message);//also have mySyslogger.info(message), but

>neither works

> 

> 

> 

>**********************code**************************

> 

> 

> 

>Can anyone throw some light on why the above code does not work? I

>checked in /var/log/messages file in my Linux machine. Nothing goes
into

>that file.

> 

> 

> 

>I also tried org.apache.log4j.net.SyslogAppender.LOG_MAIL, but did not

>see anything going into /var/log/mail file.

> 

> 

> 

>Can any one help me on this

> 

> 

> 

>Thanks in advance,

> 

> 

> 

>Pramodh Peddi.

> 

> 

> 

> 

> 

> 

>  

> 

 

-- 

 

*Paul Smith

*Software Architect

 

      

 

*Aconex

* 31 Drummond Street, Carlton, VIC 3053, Australia

*Tel: +61 3 9661 0200  *Fax: +61 3 9654 9946

Email: psmith@aconex.com  www.aconex.com**

 

This email and any attachments are intended solely for the addressee. 

The contents may be privileged, confidential and/or subject to copyright


or other applicable law. No confidentiality or privilege is lost by an 

erroneous transmission. If you have received this e-mail in error, 

please let us know by reply e-mail and delete or destroy this mail and 

all copies. If you are not the intended recipient of this message you 

must not disseminate, copy or take any action in reliance on it. The 

sender takes no responsibility for the effect of this message upon the 

recipient's computer system.**

 

 

---------------------------------------------------------------------

To unsubscribe, e-mail: log4j-user-unsubscribe@logging.apache.org

For additional commands, e-mail: log4j-user-help@logging.apache.org

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message