logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank Conover (JIRA)" <j...@apache.org>
Subject [jira] [Created] (LOG4J2-1614) Package attribute for discovering custom plugins within jars fails
Date Tue, 27 Sep 2016 01:45:21 GMT
Frank Conover created LOG4J2-1614:
-------------------------------------

             Summary: Package attribute for discovering custom plugins within jars fails
                 Key: LOG4J2-1614
                 URL: https://issues.apache.org/jira/browse/LOG4J2-1614
             Project: Log4j 2
          Issue Type: Bug
          Components: Appenders, Core
    Affects Versions: 2.6.2, 2.3
            Reporter: Frank Conover


I am experiencing this issue with 2.6.3 and I tried 2.3. I have a custom plugin in a jar file.
Works fine from eclipse, or a non-jar java app but not as a jar project. I have packages="...
attribute filled out in my log4j2.xml. I added it to get the custom appender found while running
from eclipse. As a non-maven program using jars which are on the classpath the appender is
not found. Is there another way I should be doing this? Is packages still fixed / or still
an available feature?
Note: If I extract my jars and run, the appender is found.

See: LOG4J2-741
This referenced issue and the stack overflow link in the description of this issue sound like
my issue. Do I need to compile with a certain flag turned on? Generate my jar a certain way?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org


Mime
View raw message