logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <ralph.go...@dslextreme.com>
Subject Re: Build failure
Date Mon, 05 Sep 2016 04:01:24 GMT
To be honest, I am surprised that DisruptorBlockingQueueFactory doesn’t fail to compile on
Java 7. Since it doesn’t I guess I am OK with leaving it but the tests have to be disabled
unless the build uses Java 8.  That class certainly must be documented as requiring Java 8.

Ralph

> On Sep 4, 2016, at 8:47 PM, Ralph Goers <ralph.goers@dslextreme.com> wrote:
> 
> Who added a dependency on Java 8?  It needs to be removed.
> 
> com/conversantmedia/util/concurrent/SpinPolicy : Unsupported major.minor version 52.0
> 
> 
> Ralph
> 
> 
> 
>> On Sep 4, 2016, at 8:40 PM, Ralph Goers <ralph.goers@dslextreme.com <mailto:ralph.goers@dslextreme.com>>
wrote:
>> 
>> So the very first thing I do when preparing to start a release is run a full build.
it failed with the errors below. I can’t do the release with build failures.
>> 
>> 
>> Tests in error: 
>> org.apache.logging.log4j.core.appender.AsyncAppenderTest.rewriteTest[2](org.apache.logging.log4j.core.appender.AsyncAppenderTest)
>>   Run 1: AsyncAppenderTest.before:65 No ListAppender named List found.
>>   Run 2: AsyncAppenderTest.after:70 NullPointer
>> 
>>   AsyncAppenderTest.testException[2] » UnsupportedClassVersion com/conversantmed...
>> 
>> Tests run: 1310, Failures: 0, Errors: 2, Skipped: 32
>> 
>> Ralph
>> 
> 


Mime
View raw message