logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Sicker <boa...@gmail.com>
Subject Re: Log4J 1.x and JDK 9
Date Thu, 14 Jul 2016 16:06:25 GMT
I'm getting a new Thinkpad in the mail today, so if I can find a copy of
JDK 1.4.2 that works in a modern Linux environment, that might work.

On 14 July 2016 at 11:02, Ralph Goers <ralph.goers@dslextreme.com> wrote:

> That would rule out building on a Mac.  I’d have to try it from a Linux
> VM.  I think Gary might have built Log4j 1 in the past.
>
> Ralph
>
> On Jul 14, 2016, at 8:52 AM, Paul Benedict <pbenedict@apache.org> wrote:
>
> Matt, I guess you need JDK 1.4.2 on your machine to have artifact
> "sun.jdk:tools:jar:1.4.2".
>
> Cheers,
> Paul
>
> On Thu, Jul 14, 2016 at 10:50 AM, Matt Sicker <boards@gmail.com> wrote:
>
>> How do you even build log4j 1.2? I get this error when I build from trunk:
>>
>> [ERROR] Failed to execute goal
>> org.apache.maven.plugins:maven-antrun-plugin:1.2:run (javadoc.resources) on
>> project log4j: Execution javadoc.resources of goal
>> org.apache.maven.plugins:maven-antrun-plugin:1.2:run failed: Plugin
>> org.apache.maven.plugins:maven-antrun-plugin:1.2 or one of its dependencies
>> could not be resolved: Could not find artifact sun.jdk:tools:jar:1.4.2 at
>> specified path
>> /Library/Java/JavaVirtualMachines/jdk1.8.0_66.jdk/Contents/Home/jre/../Classes/classes.jar
>> -> [Help 1]
>>
>> On 14 July 2016 at 10:47, Remko Popma <remko.popma@gmail.com> wrote:
>>
>>> Why would we want to do that? We need to make sure that Log4j 2 works
>>> well with Java 9, but otherwise I think this is an excellent opportunity
>>> for users to upgrade to Log4j 2.
>>>
>>> Remko
>>>
>>>
>>> On Thu, Jul 14, 2016 at 11:56 PM, Paul Benedict <pbenedict@apache.org>
>>> wrote:
>>>
>>>> According to this poster, it appears 1.x is not compatible with JDK 9:
>>>> http://mail.openjdk.java.net/pipermail/jigsaw-dev/2016-July/008654.html
>>>>
>>>> I told them I would notify our development community. So here's the
>>>> notification. :-)
>>>>
>>>> Given how widely used 1.x is still, what do you guys think of one more
>>>> 1.x release? Usually I would never entertain the suggestion, but this may
>>>> be the one time the justification makes sense. For those who still use 1.x
>>>> and have no time to upgrade to 2.x, I can't think of a better way to
>>>> support the user community than fix this issue.
>>>>
>>>> PS: Inside the post is a link to the supposed patch.
>>>>
>>>> WDYT?
>>>>
>>>> Cheers,
>>>> Paul
>>>>
>>>
>>>
>>
>>
>> --
>> Matt Sicker <boards@gmail.com>
>>
>
>
>


-- 
Matt Sicker <boards@gmail.com>

Mime
View raw message