logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Sicker (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (LOG4J2-1313) <Property name="" value="" /> not working
Date Wed, 09 Mar 2016 16:49:40 GMT

     [ https://issues.apache.org/jira/browse/LOG4J2-1313?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Matt Sicker updated LOG4J2-1313:
--------------------------------
    Description: 
The documentation shows examples of the property tag like this ([http://logging.apache.org/log4j/2.x/manual/configuration.html#ConfigurationSyntax]):

{noformat}
<Properties>
    <Property name="name1">value</property>
    <Property name="name2" value="value2"/>
  </Properties>
{noformat}

When using the later one with the value attribute you'll get on startup this error:

{noformat}
ERROR Property contains an invalid element or attribute "value"
{noformat}

It would be good to have the attribute support working as well, as otherwise it might happen
that IDE auto formatting is line breaking an attribute. If this isn't possible please update
the documentation.

  was:
The documentation shows examples of the property tag like this (http://logging.apache.org/log4j/2.x/manual/configuration.html#ConfigurationSyntax):

{noformat}
<Properties>
    <Property name="name1">value</property>
    <Property name="name2" value="value2"/>
  </Properties>
{noformat}

When using the later one with the value attribute you'll get on startup this error:

{noformat}
ERROR Property contains an invalid element or attribute "value"
{noformat}

It would be good to have the attribute support working as well, as otherwise it might happen
that IDE auto formatting is line breaking an attribute. If this isn't possible please update
the documentation.


> <Property name="" value="" /> not working
> -----------------------------------------
>
>                 Key: LOG4J2-1313
>                 URL: https://issues.apache.org/jira/browse/LOG4J2-1313
>             Project: Log4j 2
>          Issue Type: Bug
>    Affects Versions: 2.5
>            Reporter: Philipp Knobel
>
> The documentation shows examples of the property tag like this ([http://logging.apache.org/log4j/2.x/manual/configuration.html#ConfigurationSyntax]):
> {noformat}
> <Properties>
>     <Property name="name1">value</property>
>     <Property name="name2" value="value2"/>
>   </Properties>
> {noformat}
> When using the later one with the value attribute you'll get on startup this error:
> {noformat}
> ERROR Property contains an invalid element or attribute "value"
> {noformat}
> It would be good to have the attribute support working as well, as otherwise it might
happen that IDE auto formatting is line breaking an attribute. If this isn't possible please
update the documentation.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org


Mime
View raw message