logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jurriaan Mous (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (LOG4J2-683) PluginProcessor outputs warning if running JRE>6
Date Wed, 25 Jun 2014 16:04:26 GMT

     [ https://issues.apache.org/jira/browse/LOG4J2-683?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jurriaan Mous updated LOG4J2-683:
---------------------------------

    Summary: PluginProcessor outputs warning if running JRE>6  (was: PluginProcessor outputs
warning if running newer JDK)

> PluginProcessor outputs warning if running JRE>6
> ------------------------------------------------
>
>                 Key: LOG4J2-683
>                 URL: https://issues.apache.org/jira/browse/LOG4J2-683
>             Project: Log4j 2
>          Issue Type: Bug
>    Affects Versions: 2.0-rc2
>         Environment: JRE 8
>            Reporter: Jurriaan Mous
>
> Output:
> warning: Supported source version 'RELEASE_6' from annotation processor 'org.apache.logging.log4j.core.config.plugins.processor.PluginProcessor'
less than -source '1.8'
> Code in PluginProcessor:
> @SupportedSourceVersion(SourceVersion.RELEASE_6)
> Should probably be:
> @SupportedSourceVersion(SourceVersion.latest())
> This way it gets the latest value from the JRE environment and will also run in JRE6



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org


Mime
View raw message