logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arthur Hsieh (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (LOG4J2-665) Unable to connect from log4j2 Client GUI to my application
Date Tue, 10 Jun 2014 07:52:01 GMT

    [ https://issues.apache.org/jira/browse/LOG4J2-665?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14026211#comment-14026211
] 

Arthur Hsieh edited comment on LOG4J2-665 at 6/10/14 7:50 AM:
--------------------------------------------------------------

Thanks Ralph, i've included in log4j-api-2.0-rc1.jar in the classpath thus able to startup
the standalone app (command below):
java -cp log4j-api-2.0-rc1.jar:log4j-core-2.0-rc1.jar:log4j-jmx-gui-2.0-rc1.jar org.apache.logging.log4j.jmx.gui.ClientGUI
localhost:9010

However, the tab on the first row is titled "LoggerContext:  sun.misc.Launcher$AppClassLoader@3b26456a",
as opposed to the "LoggerContext: AsyncLoggerContext" as per http://logging.apache.org/log4j/2.x/manual/jmx.html#ClientGUI

Further, nothing is displayed under the StatusLogger tab.  When I click on the Configuration
Tab, and click on Reconfigure from Location (/Users/arthurhsieh/Documents/NetBeansProjects/AES/POS/build/classes/log4j2.xml),
StatusLogger tab is refreshed with a bunch of warning (can't copy from the panel so i've attached
the screenshot).

I've also attached my log4j2.xml

Lastly, if I startup the Client GUI as a JConsole plug-in, I still don't see a Log4j2 tab.

Thanks.


was (Author: arthur.hsieh):
Thanks Ralph, i've included in log4j-api-2.0-rc1.jar in the classpath thus able to startup
the standalone app (command below):
java -cp log4j-api-2.0-rc1.jar:log4j-core-2.0-rc1.jar:log4j-jmx-gui-2.0-rc1.jar org.apache.logging.log4j.jmx.gui.ClientGUI
localhost:9010

However, the tab on the first row is titled "LoggerContext:  sun.misc.Launcher$AppClassLoader@3b26456a",
as opposed to the AsyncLoggerContext as per http://logging.apache.org/log4j/2.x/manual/jmx.html#ClientGUI

Further, nothing is displayed under the StatusLogger tab.  When I click on the Configuration
Tab, and click on Reconfigure from Location (/Users/arthurhsieh/Documents/NetBeansProjects/AES/POS/build/classes/log4j2.xml),
StatusLogger tab is refreshed with a bunch of warning (can't copy from the panel so i've attached
the screenshot).

I've also attached my log4j2.xml

Lastly, if I startup the Client GUI as a JConsole plug-in, I still don't see a Log4j2 tab.

Thanks.

> Unable to connect from log4j2 Client GUI to my application
> ----------------------------------------------------------
>
>                 Key: LOG4J2-665
>                 URL: https://issues.apache.org/jira/browse/LOG4J2-665
>             Project: Log4j 2
>          Issue Type: Bug
>          Components: JMX
>    Affects Versions: 2.0-rc1
>         Environment: OS: OSX Mavericks 10.9.3
> IDE: Netbeans 8.0 (Build 201403101706)
> Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
> log4j: 2.0rc1
>            Reporter: Arthur Hsieh
>         Attachments: Screen Shot 2014-06-10 at 15.41.36.png, Screen Shot 2014-06-10 at
15.42.33.png, log4j2.xml
>
>
> I am unable to connect from the log4j2 Client GUI, regardless of whether running it as
a JConsole Plug-in, or running it as a standalone application.
> Below are details of what I've used in my attempts:
> My application
> - ran from Netbeans, with these VM arguments:
> -Djava.security.policy=~/Downloads/policy -Djavax.management.builder.initial= -Dcom.sun.management.jmxremote
-Dcom.sun.management.jmxremote.port=9010 -Dcom.sun.management.jmxremote.local.only=false -Dcom.sun.management.jmxremote.authenticate=false
-Dcom.sun.management.jmxremote.ssl=false
> - I've tried various ports: 9010, 1099, 33445 etc
> - Content of my policy file (I've allowed everything):
> grant {
> permission java.security.AllPermission;
> };
> Running the Client GUI as a JConsole Plug-in
> - command I used to execute:
> jconsole -pluginpath ~/Downloads/Software/Development/Java/log4j/2.0/rc1/apache-log4j-2.0-rc1-bin/log4j-core-2.0-rc1.jar:~/Downloads/Software/Development/Java/log4j/2.0/rc1/apache-log4j-2.0-rc1-bin/log4j-jmx-gui-2.0-rc1.jar
> - The JConsole starts without issue, but I don't see the Log4j2 tab as per the manual
(http://logging.apache.org/log4j/2.x/manual/jmx.html)
> Running the Client GUI as a Stand-alone Application
> - command I used to execute (I'm running this from the directory where the JARs are:
> java -cp log4j-core-2.0-rc1.jar:log4j-jmx-gui-2.0-rc1.jar org.apache.logging.log4j.jmx.gui.ClientGUI
localhost:9010
> - however, i getting a java.lang.NoClassDefFoundError:
> Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError: org/apache/logging/log4j/status/StatusLogger
>         at org.apache.logging.log4j.core.jmx.Server.<clinit>(Server.java:59)
>         at org.apache.logging.log4j.jmx.gui.Client.getStatusLoggerAdmin(Client.java:143)
>         at org.apache.logging.log4j.jmx.gui.ClientGUI.addWidgetForLoggerContext(ClientGUI.java:109)
>         at org.apache.logging.log4j.jmx.gui.ClientGUI.populateWidgets(ClientGUI.java:98)
>         at org.apache.logging.log4j.jmx.gui.ClientGUI.<init>(ClientGUI.java:81)
>         at org.apache.logging.log4j.jmx.gui.ClientGUI$2.run(ClientGUI.java:276)
>         at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
>         at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
>         at java.awt.EventQueue.access$200(EventQueue.java:103)
>         at java.awt.EventQueue$3.run(EventQueue.java:694)
>         at java.awt.EventQueue$3.run(EventQueue.java:692)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
>         at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
>         at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
>         at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
>         at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
>         at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
>         at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
>         at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
> Caused by: java.lang.ClassNotFoundException: org.apache.logging.log4j.status.StatusLogger
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
>         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
>         ... 20 more



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org


Mime
View raw message