logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <ralph.go...@dslextreme.com>
Subject Re: Bridge to other logging APIs
Date Sat, 20 Jul 2013 23:09:43 GMT
Why do you dislike including "api" in the name.  I have a problem with "bridge" because to
me it implies that I also need the Log4j 1.2 jar.  I prefer the current name because it provides
the Log4j 1.2 API (not the Log4j 1.2 implementation).  The fact that it is part of Log4j 2.0
should make it obvious that it binds that API to Log4j 2.0.

Please note that I am at the point where I don't believe anyone will be happy with whatever
name is chosen and so I would prefer to leave them alone.  In [1] below you will see the request
to group them all under the "adapters" groupId and then under [2] the request to bring them
back to core and then in [3] to leave them in core but rename them to "bridge".

[1] http://marc.info/?t=134747176600003&r=1&w=2
[2] http://marc.info/?t=136560014200006&r=1&w=2
[3] http://marc.info/?t=137411336500001&r=1&w=2


Ralph

On Jul 20, 2013, at 7:04 AM, Remko Popma wrote:

> I realize I made a mistake: I would like to rename the log4j-1.2-api jar to log4j-1.2-bridge-2.0.jar
(without api in the name).
> 
> From: Gary Gregory <garydgregory@gmail.com>; 
> To: Log4J Developers List <log4j-dev@logging.apache.org>; 
> Subject: Re: Bridge to other logging APIs 
> Sent: Thu, Jul 18, 2013 2:24:07 AM 
> 
> I also find the inconsistency  in naming confusing. I always have to read the description
to remind myself what direction a module follows.
> 
> Gary
> 
> 
> On Wed, Jul 17, 2013 at 10:11 PM, Nick Williams <nicholas@nicholaswilliams.net>
wrote:
> Agreed, on all counts.
> 
> Nick
> 
> 
> On Jul 17, 2013, at 9:07 PM, Remko Popma wrote:
> 
>> Currently we have three different names for things that provide a bridge/adapter
from other logging APIs to the Log4j2 implementation:
>> (Commons Logging) Bridge, (Log4j 1.2) API, and (SLF4J) Binding.
>> 
>> Would it be a good idea to call them all "Bridge"?
>> 
>> On the web site, components would then become:
>> Commons Logging Bridge, Log4j 1.2 Bridge, and SLF4J Bridge.
>> 
>> The jar files would become:
>> log4j-jcl-bridge-2.0.jar
>> log4j-1.2-api-bridge-2.0.jar
>> log4j-slf4j-bridge-2.0.jar
>> 
>> I would especially like to rename log4j-1.2-api-2.0.jar so we only have one jar with
"api" in the name.
>> 
>> Thoughts?
> 
> 
> 
> 
> -- 
> E-Mail: garydgregory@gmail.com | ggregory@apache.org 
> Java Persistence with Hibernate, Second Edition
> JUnit in Action, Second Edition
> Spring Batch in Action
> Blog: http://garygregory.wordpress.com 
> Home: http://garygregory.com/
> Tweet! http://twitter.com/GaryGregory


Mime
View raw message