logging-log4j-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralph Goers (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (LOG4J2-201) Having 'type' and 'elementType' on plugin is confusing
Date Sun, 05 May 2013 03:36:16 GMT

     [ https://issues.apache.org/jira/browse/LOG4J2-201?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Ralph Goers resolved LOG4J2-201.

       Resolution: Fixed
    Fix Version/s: 2.0-beta6
         Assignee: Ralph Goers

Renamed Plugin annotation attribute "type" to "category" in revision 1479232. Please verify
and close.
> Having 'type' and 'elementType' on plugin is confusing
> ------------------------------------------------------
>                 Key: LOG4J2-201
>                 URL: https://issues.apache.org/jira/browse/LOG4J2-201
>             Project: Log4j 2
>          Issue Type: Improvement
>            Reporter: Scott Deboy
>            Assignee: Ralph Goers
>             Fix For: 2.0-beta6
> Type isn't a very descriptive name for a plugin attribute, and elementType isn't much
better.  The two of them together lead to confusion.
> Are there better names we can use?
> The list of 'types' include core, converter, fileconverter (slightly confusing), configurationfactory,
lookup and keyprovider...
> The list of 'elementTypes' is larger, and includes appender, layout, advertiser, etc...
> It would be great if we could find another name for one of these..preferably 'type'...how

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

To unsubscribe, e-mail: log4j-dev-unsubscribe@logging.apache.org
For additional commands, e-mail: log4j-dev-help@logging.apache.org

View raw message